aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-01 10:55:13 -0400
committerArmin Kuster <akuster808@gmail.com>2017-11-15 16:31:30 -0800
commitb9e0b2abd1074f846bb3aef3670c0a461f6b1d00 (patch)
tree964c9b250879569efced59f4d79c1a3d75bbdcdc /meta-python/recipes-devtools/python
parent8dd8dfd2c6670c8243bae64673bae9e12055768a (diff)
downloadmeta-openembedded-contrib-b9e0b2abd1074f846bb3aef3670c0a461f6b1d00.tar.gz
python-constantly: add a recipe for version 15.1.0
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-constantly.inc11
-rw-r--r--meta-python/recipes-devtools/python/python-constantly_15.1.0.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb2
3 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-constantly.inc b/meta-python/recipes-devtools/python/python-constantly.inc
new file mode 100644
index 0000000000..8153504929
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-constantly.inc
@@ -0,0 +1,11 @@
+DESCRIPTION = "Symbolic constants in Python"
+HOMEPAGE = "https://github.com/twisted/constantly"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e393e4ddd223e3a74982efa784f89fd7"
+
+SRC_URI[md5sum] = "f0762f083d83039758e53f8cf0086eef"
+SRC_URI[sha256sum] = "586372eb92059873e29eba4f9dec8381541b4d3834660707faf8ba59146dfc35"
+
+inherit pypi
+
+RDEPENDS_${PN} += "${PYTHON_PN}-json"
diff --git a/meta-python/recipes-devtools/python/python-constantly_15.1.0.bb b/meta-python/recipes-devtools/python/python-constantly_15.1.0.bb
new file mode 100644
index 0000000000..29b15eb605
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-constantly_15.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-constantly.inc
diff --git a/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb b/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb
new file mode 100644
index 0000000000..3f667540d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-constantly_15.1.0.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-constantly.inc