aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorFranz Forstmayr <franz.forstmayr@rosenberger.com>2018-05-30 07:40:28 +0200
committerKhem Raj <raj.khem@gmail.com>2018-05-30 09:52:36 -0700
commitd37415eb2a991a87f84648fb00ac3560ff029c32 (patch)
tree5a076df0d58c7041d5190c1bc26b95704cdbce9d /meta-python/recipes-devtools/python
parent2fa700209a9276234c2e91f683054a222c6e2773 (diff)
downloadmeta-openembedded-contrib-d37415eb2a991a87f84648fb00ac3560ff029c32.tar.gz
Added python-flask-sijax package
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-flask-sijax.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-flask-sijax_0.4.1.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-sijax_0.4.1.bb4
3 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-sijax.inc b/meta-python/recipes-devtools/python/python-flask-sijax.inc
new file mode 100644
index 0000000000..ff4e70a53c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-sijax.inc
@@ -0,0 +1,8 @@
+DESCRIPTION = "An extension for the Flask microframework that adds Sijax support."
+HOMEPAGE = "https://github.com/spantaleev/flask-sijax"
+LICENSE = "BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=266adc7b911b7c84b837bf77196e1ba6"
+
+PYPI_PACKAGE = "Flask-Sijax"
+RDEPENDS_${PN} = "${PYTHON_PN}-sijax" \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python-flask-sijax_0.4.1.bb b/meta-python/recipes-devtools/python/python-flask-sijax_0.4.1.bb
new file mode 100644
index 0000000000..74738fc2f2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-sijax_0.4.1.bb
@@ -0,0 +1,4 @@
+inherit pypi setuptools
+require python-flask-sijax.inc
+
+SRC_URI[sha256sum] = "fb2bf2d4f75408185102195055d75549fee8d9c9e954dca2427186925cdc429f" \ No newline at end of file
diff --git a/meta-python/recipes-devtools/python/python3-flask-sijax_0.4.1.bb b/meta-python/recipes-devtools/python/python3-flask-sijax_0.4.1.bb
new file mode 100644
index 0000000000..e9a65c4aef
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-sijax_0.4.1.bb
@@ -0,0 +1,4 @@
+inherit pypi setuptools3
+require python-flask-sijax.inc
+
+SRC_URI[sha256sum] = "fb2bf2d4f75408185102195055d75549fee8d9c9e954dca2427186925cdc429f" \ No newline at end of file