aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-12-22 15:51:57 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-27 07:25:02 -0800
commit3182908c651fc768c04bf29c957d78b8cf949b11 (patch)
tree00eae92c9f29b1a628812445504f9ec7b7bbe457 /meta-python/recipes-devtools/python
parent048ab14c464471b76216992803da18796090d610 (diff)
downloadmeta-openembedded-contrib-3182908c651fc768c04bf29c957d78b8cf949b11.tar.gz
python-django: update to version 1.11.8
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-django.inc18
-rw-r--r--meta-python/recipes-devtools/python/python-django_1.11.8.bb (renamed from meta-python/recipes-devtools/python/python-django_1.11.5.bb)2
-rw-r--r--meta-python/recipes-devtools/python/python3-django_1.11.5.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-django_1.11.8.bb7
4 files changed, 23 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python-django.inc b/meta-python/recipes-devtools/python/python-django.inc
index e4ed860d7e..fec53791b5 100644
--- a/meta-python/recipes-devtools/python/python-django.inc
+++ b/meta-python/recipes-devtools/python/python-django.inc
@@ -3,8 +3,8 @@ HOMEPAGE = "http://www.djangoproject.com/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f09eb47206614a4954c51db8a94840fa"
-SRC_URI[md5sum] = "8cef0d42aabacbc414ec4fbbb6056f3c"
-SRC_URI[sha256sum] = "1836878162dfdf865492bacfdff0321e4ee8f1e7d51d93192546000b54982b29"
+SRC_URI[md5sum] = "e8b68d44b87a3de36e13547ec2722af2"
+SRC_URI[sha256sum] = "fed3e79bb5a3a8d5eb054c7a1ec1de229ef3f43335a67821cc3e489e9582f711"
PYPI_PACKAGE = "Django"
inherit pypi
@@ -14,11 +14,21 @@ FILES_${PN} += "${datadir}/django"
BBCLASSEXTEND = "native nativesdk"
RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-argparse \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-ctypes \
${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-html \
${PYTHON_PN}-importlib \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-multiprocessing \
+ ${PYTHON_PN}-netserver \
${PYTHON_PN}-numbers \
- ${PYTHON_PN}-pip \
${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-pytz \
${PYTHON_PN}-subprocess \
${PYTHON_PN}-threading \
- "
+ ${PYTHON_PN}-unixadmin \
+ ${PYTHON_PN}-xml \
+"
diff --git a/meta-python/recipes-devtools/python/python-django_1.11.5.bb b/meta-python/recipes-devtools/python/python-django_1.11.8.bb
index ccd7714e9f..ed92c9bfe0 100644
--- a/meta-python/recipes-devtools/python/python-django_1.11.5.bb
+++ b/meta-python/recipes-devtools/python/python-django_1.11.8.bb
@@ -1,2 +1,4 @@
require python-django.inc
inherit setuptools
+
+RDEPENDS_${PN} += "${PYTHON_PN}-zlib"
diff --git a/meta-python/recipes-devtools/python/python3-django_1.11.5.bb b/meta-python/recipes-devtools/python/python3-django_1.11.5.bb
deleted file mode 100644
index e1e38c3225..0000000000
--- a/meta-python/recipes-devtools/python/python3-django_1.11.5.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require python-django.inc
-inherit setuptools3
diff --git a/meta-python/recipes-devtools/python/python3-django_1.11.8.bb b/meta-python/recipes-devtools/python/python3-django_1.11.8.bb
new file mode 100644
index 0000000000..ef77603a62
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-django_1.11.8.bb
@@ -0,0 +1,7 @@
+require python-django.inc
+inherit setuptools3
+
+# Requires _pydecimal which is in misc
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-misc \
+"