aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDaniela Plascencia <daniela.plascencia@linux.intel.com>2017-06-20 12:20:06 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-06-22 16:03:01 +0200
commit1934a77b0a084b1b4523c5e6297534edc0b7edb0 (patch)
treef26d3bd77bdcc0a202b52af10cfb8b4aae3ff287 /meta-python/recipes-devtools
parent12e8df00c0282938363f2400b520f64d31222f51 (diff)
downloadmeta-openembedded-contrib-1934a77b0a084b1b4523c5e6297534edc0b7edb0.tar.gz
python-wrapt: adds Python3 support
Extend the recipe for Python3 support. Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-wrapt.inc15
-rw-r--r--meta-python/recipes-devtools/python/python-wrapt_1.10.10.bb17
-rw-r--r--meta-python/recipes-devtools/python/python3-wrapt_1.10.10.bb2
3 files changed, 19 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-wrapt.inc b/meta-python/recipes-devtools/python/python-wrapt.inc
new file mode 100644
index 0000000000..19668c008f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-wrapt.inc
@@ -0,0 +1,15 @@
+SUMMARY = "A Python module for decorators, wrappers and monkey patching."
+HOMEPAGE = "http://wrapt.readthedocs.org/"
+LICENSE = "BSD"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=82704725592991ea88b042d150a66303"
+
+SRC_URI[md5sum] = "97365e906afa8b431f266866ec4e2e18"
+SRC_URI[sha256sum] = "42160c91b77f1bc64a955890038e02f2f72986c01d462d53cb6cb039b995cdd9"
+
+inherit pypi
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+"
diff --git a/meta-python/recipes-devtools/python/python-wrapt_1.10.10.bb b/meta-python/recipes-devtools/python/python-wrapt_1.10.10.bb
index ee50842123..bb42476574 100644
--- a/meta-python/recipes-devtools/python/python-wrapt_1.10.10.bb
+++ b/meta-python/recipes-devtools/python/python-wrapt_1.10.10.bb
@@ -1,15 +1,2 @@
-SUMMARY = "A Python module for decorators, wrappers and monkey patching."
-HOMEPAGE = "http://wrapt.readthedocs.org/"
-LICENSE = "BSD"
-SECTION = "devel/python"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=82704725592991ea88b042d150a66303"
-
-SRC_URI[md5sum] = "97365e906afa8b431f266866ec4e2e18"
-SRC_URI[sha256sum] = "42160c91b77f1bc64a955890038e02f2f72986c01d462d53cb6cb039b995cdd9"
-
-inherit setuptools pypi
-
-RDEPENDS_${PN}_class-target += "\
- ${PYTHON_PN}-stringold \
- ${PYTHON_PN}-threading \
-"
+inherit setuptools
+require python-wrapt.inc
diff --git a/meta-python/recipes-devtools/python/python3-wrapt_1.10.10.bb b/meta-python/recipes-devtools/python/python3-wrapt_1.10.10.bb
new file mode 100644
index 0000000000..85f446ef98
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-wrapt_1.10.10.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-wrapt.inc