aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorBill Randle <bill.randle@gmail.com>2017-12-07 21:45:39 -0800
committerArmin Kuster <akuster808@gmail.com>2017-12-22 19:43:38 -0800
commitdd38e0e3f2666acbac5863df648124e9669817bc (patch)
tree08afa7426bcd63c15177e7d985f408030fd0db18 /meta-python/recipes-devtools
parentacfb8417e370d017e7307872e61564deeda76a13 (diff)
downloadmeta-openembedded-contrib-dd38e0e3f2666acbac5863df648124e9669817bc.tar.gz
python-flask-bootstrap: move core of recipe to a .inc file
Signed-off-by: Bill Randle <bill.randle@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-flask-bootstrap.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-flask-bootstrap_3.3.7.1.bb16
2 files changed, 15 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-bootstrap.inc b/meta-python/recipes-devtools/python/python-flask-bootstrap.inc
new file mode 100644
index 0000000000..0723b97383
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask-bootstrap.inc
@@ -0,0 +1,14 @@
+DESCRIPTION = "An extension that includes Bootstrap in your project, without any boilerplate code."
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a03749709f06118a17349deb5a210619"
+
+SRC_URI[md5sum] = "e40d50f5c5b6438c1c6200a6f2871f81"
+SRC_URI[sha256sum] = "cb08ed940183f6343a64e465e83b3a3f13c53e1baabb8d72b5da4545ef123ac8"
+
+PYPI_PACKAGE = "Flask-Bootstrap"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-dominate \
+ ${PYTHON_PN}-flask \
+ ${PYTHON_PN}-visitor \
+ "
diff --git a/meta-python/recipes-devtools/python/python-flask-bootstrap_3.3.7.1.bb b/meta-python/recipes-devtools/python/python-flask-bootstrap_3.3.7.1.bb
index 2b2a6f9bda..eeaade9a88 100644
--- a/meta-python/recipes-devtools/python/python-flask-bootstrap_3.3.7.1.bb
+++ b/meta-python/recipes-devtools/python/python-flask-bootstrap_3.3.7.1.bb
@@ -1,16 +1,2 @@
-DESCRIPTION = "An extension that includes Bootstrap in your project, without any boilerplate code."
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a03749709f06118a17349deb5a210619"
-
-SRC_URI[md5sum] = "e40d50f5c5b6438c1c6200a6f2871f81"
-SRC_URI[sha256sum] = "cb08ed940183f6343a64e465e83b3a3f13c53e1baabb8d72b5da4545ef123ac8"
-
-PYPI_PACKAGE = "Flask-Bootstrap"
-
inherit pypi setuptools
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-dominate \
- ${PYTHON_PN}-flask \
- ${PYTHON_PN}-visitor \
- "
+require python-flask-bootstrap.inc