aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2014-07-30 14:11:18 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2014-08-01 14:23:46 +0200
commita1db099fc7015497174f5aabf4fe273e5b4c5304 (patch)
tree3679c78878edb8e51cbce928f81f0035b60eccc1 /meta-python/recipes-devtools
parent9ee63821708901d535b87d28042b512bd1a67eca (diff)
downloadmeta-openembedded-contrib-a1db099fc7015497174f5aabf4fe273e5b4c5304.tar.gz
python-decorator: add recipe
Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-decorator_3.4.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-decorator_3.4.0.bb b/meta-python/recipes-devtools/python/python-decorator_3.4.0.bb
new file mode 100644
index 0000000000..43166304a2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-decorator_3.4.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Python decorator utilities"
+HOMEPAGE = "http://pypi.python.org/pypi/decorator/"
+DESCRIPTION = "\
+The aim of the decorator module it to simplify the usage of decorators \
+for the average programmer, and to popularize decorators by showing \
+various non-trivial examples. Of course, as all techniques, decorators \
+can be abused and you should not try to solve every problem with a \
+decorator, just because you can."
+
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://documentation3.py;beginline=848;endline=877;md5=0b56661417fb7b841afc8892e14ba241"
+
+SRCNAME = "decorator"
+
+SRC_URI = "https://pypi.python.org/packages/source/d/decorator/decorator-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+SRC_URI[md5sum] = "1e8756f719d746e2fc0dd28b41251356"
+SRC_URI[sha256sum] = "c20b404cbb7ee5cebd506688e0114e3cd76f5ce233805a51f36e1a7988d9d783"