aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2016-06-02 23:12:47 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:28 +0200
commit7650008ed9294ec272ecbc6f5a4ef8872830e2e1 (patch)
treee7cca84c369119a44d187d8926f17699be9c32c3 /meta-python
parent4c110ff936390c9c4a908eb9cc0de8beec241eb3 (diff)
downloadmeta-openembedded-contrib-7650008ed9294ec272ecbc6f5a4ef8872830e2e1.tar.gz
python-singledispatch: initial recipe for version 3.4.0.3
This package backports functools.singledispatch from Python 3.4 to earlier Python versions. It is being added as one of the two missing backport modules that Tornado 4.3 needs in order to prevent tornado/gen.py from bombing on import errors when running on python2 rather than python3.4 ImportError: No module named singledispatch Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-singledispatch_3.4.0.3.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-singledispatch_3.4.0.3.bb b/meta-python/recipes-devtools/python/python-singledispatch_3.4.0.3.bb
new file mode 100644
index 0000000000..87f46e5909
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-singledispatch_3.4.0.3.bb
@@ -0,0 +1,13 @@
+SUMMARY = "functools.singledispatch from Python 3.4"
+DESCRIPTION = "PEP 443 proposed to expose a mechanism in the functools standard library module \
+in Python 3.4 that provides a simple form of generic programming known as single-dispatch \
+generic functions. This library is a backport of this functionality to Python 2.6 - 3.3"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=ee3cd67264adc7eb07981f3644dc17dc"
+
+SRC_URI[md5sum] = "af2fc6a3d6cc5a02d0bf54d909785fcb"
+SRC_URI[sha256sum] = "5b06af87df13818d14f08a028e42f566640aef80805c3b50c5056b086e3c2b9c"
+
+PYPI_PACKAGE = "singledispatch"
+inherit pypi setuptools