aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-09-19 14:51:50 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-22 22:50:46 +0000
commitc134e806376e53eb07814cb6a35b1f544598b456 (patch)
treed2bd007e8c4f759b89db923637dbe01cae8b9e7a /meta-python
parent60d327c66570b770a18cd1b06526693241170a56 (diff)
downloadmeta-openembedded-contrib-c134e806376e53eb07814cb6a35b1f544598b456.tar.gz
python-appdirs: add an initial recipe
A small Python module for determining appropriate + platform-specific dirs Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-appdirs.inc8
-rw-r--r--meta-python/recipes-devtools/python/python-appdirs_1.4.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-appdirs_1.4.3.bb2
3 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-appdirs.inc b/meta-python/recipes-devtools/python/python-appdirs.inc
new file mode 100644
index 0000000000..c4826723e8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-appdirs.inc
@@ -0,0 +1,8 @@
+SUMMARY = "A small Python module for determining appropriate + platform-specific dirs, e.g. a user data dir."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=31625363c45eb0c67c630a2f73e438e4"
+
+SRC_URI[md5sum] = "44c679904082a2133f5566c8a0d3ab42"
+SRC_URI[sha256sum] = "9e5896d1372858f8dd3344faf4e5014d21849c756c8d5701f78f8a103b372d92"
+
+inherit pypi
diff --git a/meta-python/recipes-devtools/python/python-appdirs_1.4.3.bb b/meta-python/recipes-devtools/python/python-appdirs_1.4.3.bb
new file mode 100644
index 0000000000..e9ff9b3fc3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-appdirs_1.4.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-appdirs.inc
diff --git a/meta-python/recipes-devtools/python/python3-appdirs_1.4.3.bb b/meta-python/recipes-devtools/python/python3-appdirs_1.4.3.bb
new file mode 100644
index 0000000000..d24e1d8b6a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-appdirs_1.4.3.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-appdirs.inc