aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-21 11:20:33 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-22 20:09:54 -0800
commit7ba61902e6ee39d5fbb4e8e10288e76a1c4468bc (patch)
treebfbbf3ad813fc744009cb0b668bd9666c1ab0dba /meta-python
parent594d12f429c98c6e05aa2c3b9cc44f319d640696 (diff)
downloadmeta-openembedded-contrib-7ba61902e6ee39d5fbb4e8e10288e76a1c4468bc.tar.gz
Remove deprecated python3-selectors from the RDEPENDS
The python3-selectors package was removed as part of the migration to the json manifest file. The functionality is now part of core Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb4
-rw-r--r--meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-pyserial_3.4.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb1
9 files changed, 1 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb b/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb
index 9d98372285..cfbe57520c 100644
--- a/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb
+++ b/meta-python/recipes-devtools/python/python3-asn1crypto_0.24.0.bb
@@ -2,6 +2,5 @@ inherit setuptools3
require python-asn1crypto.inc
RDEPENDS_${PN}_class-target += " \
- ${PYTHON_PN}-selectors \
${PYTHON_PN}-shell \
"
diff --git a/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb b/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
index e28389ef1e..091eb368a5 100644
--- a/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dnspython_1.15.0.bb
@@ -4,5 +4,4 @@ require python-dnspython.inc
# Requires _pydecimal.py which is in misc
RDEPENDS_${PN} += " \
${PYTHON_PN}-misc \
- ${PYTHON_PN}-selectors \
"
diff --git a/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb b/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb
index bd2bcb3deb..70813bf34c 100644
--- a/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-hyperlink_17.3.1.bb
@@ -1,4 +1,2 @@
inherit setuptools3
require python-hyperlink.inc
-
-RDEPENDS_${PN} += "${PYTHON_PN}-selectors"
diff --git a/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb b/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
index be55770dda..30416a4ffe 100644
--- a/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
+++ b/meta-python/recipes-devtools/python/python3-netaddr_0.7.19.bb
@@ -1,6 +1,2 @@
require python-netaddr.inc
inherit setuptools3
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-selectors \
-"
diff --git a/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb b/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb
index 997b0cad78..93df83ad3c 100644
--- a/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb
+++ b/meta-python/recipes-devtools/python/python3-ntplib_0.3.3.bb
@@ -11,4 +11,4 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit setuptools3 python3native pypi
-RDEPENDS_${PN} += "${PYTHON_PN}-datetime ${PYTHON_PN}-selectors"
+RDEPENDS_${PN} += "${PYTHON_PN}-datetime"
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
index 55b0314a05..e6e9726178 100644
--- a/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pymongo_3.6.0.bb
@@ -4,6 +4,5 @@ require python-pymongo.inc
# Requires _pydecimal which is in misc
RDEPENDS_${PYTHON_PN}-bson += " \
${PYTHON_PN}-misc \
- ${PYTHON_PN}-selectors \
${PYTHON_PN}-subprocess \
"
diff --git a/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb b/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
index 6807b9510e..17ed3f8bc4 100644
--- a/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
+++ b/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
@@ -5,5 +5,3 @@ do_install_append() {
rm -f ${D}${bindir}/miniterm.py
rmdir ${D}${bindir}
}
-
-RDEPENDS_${PN} += "${PYTHON_PN}-selectors"
diff --git a/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb b/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb
index e5f00e871c..bbda05a518 100644
--- a/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb
+++ b/meta-python/recipes-devtools/python/python3-pysocks_1.6.8.bb
@@ -3,5 +3,4 @@ require python-pysocks.inc
RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-netclient \
- ${PYTHON_PN}-selectors \
"
diff --git a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
index b8dc1741b9..8ad1c17478 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
+++ b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
@@ -4,5 +4,4 @@ require python-whoosh.inc
# Requires _pydecimal.py which is in misc
RDEPENDS_${PN} += " \
${PYTHON_PN}-misc \
- ${PYTHON_PN}-selectors \
"