aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorS. Lockwood-Childs <sjl@vctlabs.com>2016-06-02 23:16:30 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-08 14:55:28 +0200
commitb5091a1a3423784e1b22faca1275be8377a3c4ff (patch)
tree0c2acb651b41952c1059afc5c29622729f625582 /meta-python
parent7650008ed9294ec272ecbc6f5a4ef8872830e2e1 (diff)
downloadmeta-openembedded-contrib-b5091a1a3423784e1b22faca1275be8377a3c4ff.tar.gz
python-tornado: add missing python2 runtime deps
Tornado 4.3 needs backports_abc and singledispatch backport modules at runtime to prevent tornado/gen.py from bombing on import errors when running on python2 rather than python3.4 Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-tornado_4.3.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-tornado_4.3.bb b/meta-python/recipes-devtools/python/python-tornado_4.3.bb
index 55a48b8841..5d11475567 100644
--- a/meta-python/recipes-devtools/python/python-tornado_4.3.bb
+++ b/meta-python/recipes-devtools/python/python-tornado_4.3.bb
@@ -1,3 +1,3 @@
inherit pypi setuptools
require python-tornado.inc
-RDEPENDS_${PN} += "${PYTHON_PN}-backports-ssl"
+RDEPENDS_${PN} += "${PYTHON_PN}-backports-ssl ${PYTHON_PN}-backports-abc ${PYTHON_PN}-singledispatch"