aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2014-10-12 22:02:22 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2014-10-14 11:48:58 +0200
commitfd1c5b8dc5c9f412036f0356cc2036803d0a41c1 (patch)
tree7d45a0589cd77bf9e815181742356400e450b94a /meta-python
parent19692ba37a82253fa8d2922f9c8fc716bd12734e (diff)
downloadmeta-openembedded-contrib-fd1c5b8dc5c9f412036f0356cc2036803d0a41c1.tar.gz
python-matplotlib: add dateutil & pytz to DEPENDS/RDEPENDS
python-matplotlib is currently providing its own dateutil and pytz Add dateutil and pytz as DEPENDS/RDEPENDS. Patch setupext.py to no longer provide its own dateutil and pytz. Remove python-matplotlib from blacklist. Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-matplotlib/fix_setupext.patch19
-rw-r--r--meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb7
2 files changed, 17 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-matplotlib/fix_setupext.patch b/meta-python/recipes-devtools/python/python-matplotlib/fix_setupext.patch
index e07159552f..9a13a1850f 100644
--- a/meta-python/recipes-devtools/python/python-matplotlib/fix_setupext.patch
+++ b/meta-python/recipes-devtools/python/python-matplotlib/fix_setupext.patch
@@ -1,9 +1,20 @@
This fixes the numpy import problem in setupext.py using a hard-coded path.
-diff --git a/setupext.py b/setupext.py
-index 962cedc..82297c4 100644
---- a/setupext.py
-+++ b/setupext.py
+Index: matplotlib-1.1.0/setupext.py
+===================================================================
+--- matplotlib-1.1.0.orig/setupext.py
++++ matplotlib-1.1.0/setupext.py
+@@ -122,8 +122,8 @@ numpy_inc_dirs = []
+ # matplotlib build options, which can be altered using setup.cfg
+ options = {'display_status': True,
+ 'verbose': False,
+- 'provide_pytz': 'auto',
+- 'provide_dateutil': 'auto',
++ 'provide_pytz': False,
++ 'provide_dateutil': False,
+ 'build_agg': True,
+ 'build_gtk': 'auto',
+ 'build_gtkagg': 'auto',
@@ -176,10 +176,7 @@ if os.path.exists(setup_cfg):
except: pass
diff --git a/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb b/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
index 6c8a202c59..69f71c7116 100644
--- a/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
+++ b/meta-python/recipes-devtools/python/python-matplotlib_1.1.0.bb
@@ -4,11 +4,8 @@ LICENSE = "PSF"
LIC_FILES_CHKSUM = "file://README.txt;md5=83c5bf8b16a5f99507f2f47a21ae3b81"
PR = "r1"
-DEPENDS += "python-numpy freetype libpng"
-RDEPENDS_${PN} = "python-core python-distutils python-numpy freetype libpng"
-
-PNBLACKLIST[python-matplotlib] = "CONFLICT: 34 files with python-dateutil"
-# e.g. sysroots/qemux86-64/usr/lib/python2.7/site-packages/dateutil/tzwin.pyc
+DEPENDS += "python-numpy freetype libpng python-dateutil python-pytz"
+RDEPENDS_${PN} = "python-core python-distutils python-numpy freetype libpng python-dateutil python-pytz"
SRC_URI = "${SOURCEFORGE_MIRROR}/matplotlib/matplotlib-${PV}.tar.gz \
file://fix_setup.patch \