aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDaniela Plascencia <daniela.plascencia@linux.intel.com>2016-10-19 09:19:38 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-26 10:28:39 +0200
commita4f713b5b1176dd408dae30c60ced28d64c12d18 (patch)
tree2fc76e21b0f06f9c2694094c6b7579b3c00a211d /meta-python
parentb6f38dd811cf6ba4a8a36c83af87a48f21022dc4 (diff)
downloadmeta-openembedded-contrib-a4f713b5b1176dd408dae30c60ced28d64c12d18.tar.gz
python-unidiff: python module for parsing diff data
The module takes diff data from commands like diff or git-format-patch, parses it and creates python objects in the form of patch sets. More info is given on the recipe metadata. Signed-off-by: Daniela Plascencia <daniela.plascencia@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-unidiff_0.5.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-unidiff_0.5.2.bb b/meta-python/recipes-devtools/python/python-unidiff_0.5.2.bb
new file mode 100644
index 0000000000..3b018c7509
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-unidiff_0.5.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Unified diff parsing/metadata extraction library"
+HOMEPAGE = "http://github.com/matiasb/python-unidiff"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4c434b08ef42fea235bb019b5e5a97b3"
+
+SRC_URI[md5sum] = "20dd70ba5a35bc95bf869322d6852227"
+SRC_URI[sha256sum] = "344330ec3637e96b44dca77e086b205645b55648cf4d2b80fc673200f8a6a7e9"
+
+inherit pypi setuptools
+
+U = "${D}${LIBDIR}${PYTHON_SITEPACKAGES_DIR}"
+
+do_install_append (){
+ mv ${U}/tests ${U}/unidiff/
+}