aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-05 12:41:56 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commit394857d81e78556ebf65b67c556a731dbc5b9645 (patch)
tree6f39c209dd13ff8d9ec2c20d4eb9088141156f61 /meta-python
parent7b5d9c4f7b763bfcded6234d4122459974530e27 (diff)
downloadmeta-openembedded-contrib-394857d81e78556ebf65b67c556a731dbc5b9645.tar.gz
python-pyrsistent: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyrsistent.inc13
-rw-r--r--meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb15
2 files changed, 14 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyrsistent.inc b/meta-python/recipes-devtools/python/python-pyrsistent.inc
deleted file mode 100644
index ae4f21af48..0000000000
--- a/meta-python/recipes-devtools/python/python-pyrsistent.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-SUMMARY = "Persistent/Immutable/Functional data structures for Python"
-HOMEPAGE = "https://github.com/tobgu/pyrsistent"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENCE.mit;md5=ca574f2891cf528b3e7a2ee570337e7c"
-
-SRC_URI[md5sum] = "da9486d00ef5b213f40d5cf3c5bca82d"
-SRC_URI[sha256sum] = "cdc7b5e3ed77bed61270a47d35434a30617b9becdf2478af76ad2c6ade307280"
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-six \
-"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb b/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb
index 2e567e9f9c..5ef7140283 100644
--- a/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb
+++ b/meta-python/recipes-devtools/python/python3-pyrsistent_0.15.7.bb
@@ -1,2 +1,15 @@
+SUMMARY = "Persistent/Immutable/Functional data structures for Python"
+HOMEPAGE = "https://github.com/tobgu/pyrsistent"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENCE.mit;md5=ca574f2891cf528b3e7a2ee570337e7c"
+
+SRC_URI[md5sum] = "da9486d00ef5b213f40d5cf3c5bca82d"
+SRC_URI[sha256sum] = "cdc7b5e3ed77bed61270a47d35434a30617b9becdf2478af76ad2c6ade307280"
+
inherit pypi setuptools3
-require python-pyrsistent.inc
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-six \
+"
+
+BBCLASSEXTEND = "native nativesdk"