aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-05 16:42:12 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 14:27:45 -0700
commitfb8ddbfe2531d6b1a848c755920cbb13ce67e691 (patch)
tree9e07c3ed6e9096c3bb71e9e201db66d5c4932536 /meta-python
parentc4d22546edf72d21a11d59dc4b23b4bf6fdd8a72 (diff)
downloadmeta-openembedded-contrib-fb8ddbfe2531d6b1a848c755920cbb13ce67e691.tar.gz
python-pycurl: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pycurl.inc25
-rw-r--r--meta-python/recipes-devtools/python/python3-pycurl_7.43.0.5.bb24
2 files changed, 22 insertions, 27 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycurl.inc b/meta-python/recipes-devtools/python/python-pycurl.inc
deleted file mode 100644
index 0f661434c0..0000000000
--- a/meta-python/recipes-devtools/python/python-pycurl.inc
+++ /dev/null
@@ -1,25 +0,0 @@
-SUMMARY = "A Python Interface To The cURL library"
-DESCRIPTION = "\
-PycURL is a Python interface to libcurl, the multiprotocol file \
-transfer library. Similarly to the urllib Python module, PycURL can \
-be used to fetch objects identified by a URL from a Python program \
-"
-SECTION = "devel/python"
-HOMEPAGE = "http://pycurl.io/"
-
-LICENSE = "LGPLv2 | MIT"
-LIC_FILES_CHKSUM = "file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \
- file://COPYING-MIT;md5=60872a112595004233b769b6cbfd65b6 \
- "
-
-SRC_URI[md5sum] = "0b387d4609ed20c88baede8579a4d425"
-SRC_URI[sha256sum] = "ec7dd291545842295b7b56c12c90ffad2976cc7070c98d7b1517b7b6cd5994b3"
-
-inherit pypi
-
-PYPI_PACKAGE = "pycurl"
-
-DEPENDS = "\
- curl \
- ${PYTHON_PN}\
-"
diff --git a/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.5.bb b/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.5.bb
index c98b7d6f60..5a1c1797ad 100644
--- a/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.5.bb
+++ b/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.5.bb
@@ -1,3 +1,23 @@
-inherit setuptools3
-require python-pycurl.inc
+SUMMARY = "A Python Interface To The cURL library"
+DESCRIPTION = "\
+PycURL is a Python interface to libcurl, the multiprotocol file \
+transfer library. Similarly to the urllib Python module, PycURL can \
+be used to fetch objects identified by a URL from a Python program \
+"
+SECTION = "devel/python"
+HOMEPAGE = "http://pycurl.io/"
+LICENSE = "LGPLv2 | MIT"
+LIC_FILES_CHKSUM = "file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING-MIT;md5=60872a112595004233b769b6cbfd65b6 \
+ "
+
+SRC_URI[md5sum] = "0b387d4609ed20c88baede8579a4d425"
+SRC_URI[sha256sum] = "ec7dd291545842295b7b56c12c90ffad2976cc7070c98d7b1517b7b6cd5994b3"
+
+inherit pypi setuptools3
+
+DEPENDS = "\
+ curl \
+ ${PYTHON_PN}\
+"