aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2018-05-19 14:43:08 -0700
committerKhem Raj <raj.khem@gmail.com>2018-05-29 12:57:23 -0700
commit75540ab1499ca9e4a2cd890012cda56620fc5a54 (patch)
tree04d1a2ed281cca9c862bfa3ae1b6ca62f166bbbe /meta-python
parentd3d269838bb3ed9ba457b9e0aceb23f8d7447446 (diff)
downloadmeta-openembedded-contrib-75540ab1499ca9e4a2cd890012cda56620fc5a54.tar.gz
python-lockfile: Fix build error as following:
"distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('pbr>=1.8')" Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb b/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb
index cd15760d46..9ad865d406 100644
--- a/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb
+++ b/meta-python/recipes-devtools/python/python-lockfile_0.12.2.bb
@@ -11,3 +11,9 @@ inherit pypi setuptools
SRC_URI[md5sum] = "a6a1a82957a23afdf44cfdd039b65ff9"
SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799"
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+