aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2018-03-06 20:17:32 -0500
committerArmin Kuster <akuster808@gmail.com>2018-03-12 10:01:16 -0700
commitaa997c97b30d016817dbf471536989c0e1b589ef (patch)
tree08391ab77c146a940ff8bc1fd9a48afa0f7acdd1 /meta-python
parentc372e227e2b7bc019ee5d9a25e92ff7f654b98d7 (diff)
downloadmeta-openembedded-contrib-aa997c97b30d016817dbf471536989c0e1b589ef.tar.gz
python3-blivet: fix invoking dd timeout caused partition failed
This large timeout is needed when running on machines with lots of disks, or with slow disks. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet/0014-invoking-dd-with-infinite-timeout.patch31
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_2.2.0.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet/0014-invoking-dd-with-infinite-timeout.patch b/meta-python/recipes-extended/python-blivet/python3-blivet/0014-invoking-dd-with-infinite-timeout.patch
new file mode 100644
index 0000000000..12a9e4f544
--- /dev/null
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet/0014-invoking-dd-with-infinite-timeout.patch
@@ -0,0 +1,31 @@
+From 92fe7dfd01131c93a9b2013cabf77d5f46900fab Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Tue, 6 Mar 2018 17:28:56 +0800
+Subject: [PATCH] invoking dd with infinite timeout
+
+This large timeout is needed when running on machines with
+lots of disks, or with slow disks.
+
+Upstream-Status: Pending
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ blivet/devices/partition.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/blivet/devices/partition.py b/blivet/devices/partition.py
+index a7372fb..8947472 100644
+--- a/blivet/devices/partition.py
++++ b/blivet/devices/partition.py
+@@ -594,7 +594,7 @@ class PartitionDevice(StorageDevice):
+ cmd = ["dd", "if=/dev/zero", "of=%s" % device, "bs=%d" % bs,
+ "seek=%d" % start, "count=%d" % count]
+ try:
+- util.run_program(cmd)
++ util.run_program(cmd, timeout=-1)
+ except OSError as e:
+ log.error(str(e))
+ finally:
+--
+1.8.3.1
+
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_2.2.0.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_2.2.0.bb
index cacca67e24..46dc32de76 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_2.2.0.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_2.2.0.bb
@@ -23,6 +23,7 @@ SRC_URI = "git://github.com/rhinstaller/blivet;branch=2.2-devel \
file://0011-invoking-fsck-with-infinite-timeout.patch \
file://0012-invoking-mkfs-with-infinite-timeout.patch \
file://0013-Revert-Adapt-to-logging-module-name-change.patch \
+ file://0014-invoking-dd-with-infinite-timeout.patch \
"
inherit distro_features_check