aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2015-04-16 08:17:44 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-24 15:11:24 +0200
commit09e3d0af9e1002c67d164df4fdc1090a15962950 (patch)
treedf57c1264af716fe1c1cfb8c37b3795972120c2b /meta-python
parent90bd90501a28849bb9ddfb401e32f47d38fd2c6a (diff)
downloadmeta-openembedded-contrib-09e3d0af9e1002c67d164df4fdc1090a15962950.tar.gz
python-pyasn1: add 0.1.7
python-pyasn1 is required by python-cryptography Copied directly from: http://git.yoctoproject.org/cgit/cgit.cgi/meta-cloud-services/tree/meta-openstack/recipes-devtools/python/python-pyasn1_0.1.7.bb Original author: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Tim Orling <TicoTimo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pyasn1_0.1.7.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyasn1_0.1.7.bb b/meta-python/recipes-devtools/python/python-pyasn1_0.1.7.bb
new file mode 100644
index 0000000000..0fe6909734
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyasn1_0.1.7.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Python library implementing ASN.1 types."
+HOMEPAGE = "http://pyasn1.sourceforge.net/"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae098273b2cf8b4af164ac20e32bddf7"
+DEPENDS = "python"
+
+SRC_URI = "https://pypi.python.org/packages/source/p/pyasn1/pyasn1-${PV}.tar.gz"
+SRC_URI[md5sum] = "2cbd80fcd4c7b1c82180d3d76fee18c8"
+SRC_URI[sha256sum] = "e4f81d53c533f6bd9526b047f047f7b101c24ab17339c1a7ad8f98b25c101eab"
+
+S = "${WORKDIR}/pyasn1-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-lang python-shell"