aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2015-02-24 10:59:57 -0300
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-03 08:35:59 +0100
commit7059882a849e885e17e76ec4057dbdedd5d1e1a0 (patch)
tree98f8a9536073609a2af6e0c24702155c372dbd55 /meta-python
parentfe27cb216186a65d7bb108b37647a287871f8eae (diff)
downloadmeta-openembedded-contrib-7059882a849e885e17e76ec4057dbdedd5d1e1a0.tar.gz
python-urllib3: add recipe for version 1.10.1
Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-urllib3_1.10.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-urllib3_1.10.1.bb b/meta-python/recipes-devtools/python/python-urllib3_1.10.1.bb
new file mode 100644
index 0000000000..89f7428009
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-urllib3_1.10.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
+HOMEPAGE = "https://github.com/shazow/urllib3"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3be3707c5f24a69709682265e29566fe"
+
+SRC_URI = "https://github.com/shazow/urllib3/archive/${PV}.zip"
+SRC_URI[md5sum] = "73935fe42b6ef51d078edbbca7c1bd55"
+SRC_URI[sha256sum] = "5fadd55b46bf826e46a482bb3d53662a8a88d8f9ea8656e351b659b8ad9bfc0f"
+
+S = "${WORKDIR}/urllib3-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-netclient"