aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-29 11:26:45 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-30 15:58:14 -0700
commitc53b1218e89ff6f917fd7264b9cc7fb7a4590bc4 (patch)
tree9fb7b45fca3fd1425b947be338b0762e6cb11811 /meta-python
parent30ed7bb022ebe6869b3e25356dc9fdf7a861e3b6 (diff)
downloadmeta-openembedded-contrib-c53b1218e89ff6f917fd7264b9cc7fb7a4590bc4.tar.gz
python3-djangorestframework: Upgrade 3.11.1 -> 3.12.1
Upgrade to release 3.12.1: - Add --file option to generateschema command. - Support tags for OpenAPI schema generation. See the schema docs. - Support customising the operation ID for schema generation. See the schema docs. - Support OpenAPI components for schema generation. See the schema docs. - The following methods on AutoSchema become public API: get_path_parameters, get_pagination_parameters, get_filter_parameters, get_request_body, get_responses, get_serializer, get_paginator, map_serializer, map_field, map_choice_field, map_field_validators, allows_filters. See the schema docs. - Add support for Django 3.1's database-agnositic JSONField. - SearchFilter now supports nested search on JSONField and HStoreField model fields. - SearchFilter now supports searching on annotate() fields. - The authtoken model no longer exposes the pk in the admin URL. - Add __repr__ for Request instances. - UTF-8 decoding with Latin-1 fallback for basic auth credentials. - CharField treats surrogate characters as a validation failure. - Don't include callables as default values in schemas. - Improve ListField schema output to include all available child information. - Allow default=False to be included for BooleanField schema outputs. - Include "type" information in ChoiceField schema outputs. - Include "type": "object" on schema objects. - Don't include component in schema output for DELETE requests. - Fix schema types for DecimalField. - Fix schema generation for ObtainAuthToken view. - Support passing context=... to view .get_serializer() methods. - Pass custom code to PermissionDenied if permission class has one set. - Include "example" in schema pagination output. - Default status code of 201 on schema output for POST requests. - Use camelCase for operation IDs in schema output. - Warn if duplicate operation IDs exist in schema output. - Improve handling of decimal type when mapping ChoiceField to a schema output. - Disable YAML aliases for OpenAPI schema outputs. - Fix action URL names for APIs included under a namespaced URL. - Update jQuery version from 3.4 to 3.5. - Fix UniqueTogether handling when serializer fields use source=.... - HTTP HEAD requests now set self.action correctly on a ViewSet instance. - Return a valid OpenAPI schema for the case where no API schema paths exist. - Include tests in package distribution. - Allow type checkers to support annotations like ModelSerializer[Author]. - Don't include invalid charset=None portion in the request Content-Type header when using APIClient. - Fix \Z/\z tokens in OpenAPI regexs. - Fix PrimaryKeyRelatedField and HyperlinkedRelatedField when source field is actually a property. - Token.generate_key is now a class method. - @action warns if method is wrapped in a decorator that does not preserve information using @functools.wraps. - Add TokenProxy migration. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-djangorestframework_3.12.1.bb (renamed from meta-python/recipes-devtools/python/python3-djangorestframework_3.11.1.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-djangorestframework_3.11.1.bb b/meta-python/recipes-devtools/python/python3-djangorestframework_3.12.1.bb
index 81f55ff9e7..60bdbaa9ec 100644
--- a/meta-python/recipes-devtools/python/python3-djangorestframework_3.11.1.bb
+++ b/meta-python/recipes-devtools/python/python3-djangorestframework_3.12.1.bb
@@ -5,8 +5,8 @@ HOMEPAGE = "https://pypi.python.org/pypi/djangorestframework"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=7879a5a716147a784f7e524c9cf103c1"
-SRC_URI[md5sum] = "c8ea3e4c3c0d705acf70184faeb2b696"
-SRC_URI[sha256sum] = "6dd02d5a4bd2516fb93f80360673bf540c3b6641fec8766b1da2870a5aa00b32"
+SRC_URI[md5sum] = "47d5ea46923a131c5fbefeb610c6ce2c"
+SRC_URI[sha256sum] = "d54452aedebb4b650254ca092f9f4f5df947cb1de6ab245d817b08b4f4156249"
PYPI_PACKAGE = "djangorestframework"
inherit pypi setuptools3