aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ruby
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-08-21 09:23:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-31 10:18:33 +0200
commit6e7c9636d276ac02f64aa48fb4fb36f9ee8f3076 (patch)
tree658dec61c0a1de40df08919102a3a0f46d25a71e /meta-ruby
parentec9e5ed06256ad92c818474cdb490dc0d3a0d0a3 (diff)
downloadmeta-openembedded-contrib-6e7c9636d276ac02f64aa48fb4fb36f9ee8f3076.tar.gz
meta-ruby: remove this now pretty empty layer
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-ruby')
-rw-r--r--meta-ruby/COPYING.MIT17
-rw-r--r--meta-ruby/README16
-rw-r--r--meta-ruby/classes/ruby.bbclass131
-rw-r--r--meta-ruby/conf/layer.conf15
4 files changed, 0 insertions, 179 deletions
diff --git a/meta-ruby/COPYING.MIT b/meta-ruby/COPYING.MIT
deleted file mode 100644
index fb950dc69f..0000000000
--- a/meta-ruby/COPYING.MIT
+++ /dev/null
@@ -1,17 +0,0 @@
-Permission is hereby granted, free of charge, to any person obtaining a copy
-of this software and associated documentation files (the "Software"), to deal
-in the Software without restriction, including without limitation the rights
-to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-copies of the Software, and to permit persons to whom the Software is
-furnished to do so, subject to the following conditions:
-
-The above copyright notice and this permission notice shall be included in
-all copies or substantial portions of the Software.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
-THE SOFTWARE.
diff --git a/meta-ruby/README b/meta-ruby/README
deleted file mode 100644
index 08e0aa7ebe..0000000000
--- a/meta-ruby/README
+++ /dev/null
@@ -1,16 +0,0 @@
-This layer depends on:
-
-URI: git://github.com/openembedded/oe-core.git
-branch: master
-revision: HEAD
-
-URI: git://github.com/openembedded/meta-oe.git
-branch: master
-revision: HEAD
-
-Send pull requests to openembedded-devel@lists.openembedded.org with '[meta-ruby]' in the subject'
-
-When sending single patches, please using something like:
-'git send-email -M -1 --to openembedded-devel@lists.openembedded.org --subject-prefix=meta-ruby][PATCH'
-
-Layer maintainer: Armin Kuster <akuster808@gmail.com>
diff --git a/meta-ruby/classes/ruby.bbclass b/meta-ruby/classes/ruby.bbclass
deleted file mode 100644
index 1acf2e0bd2..0000000000
--- a/meta-ruby/classes/ruby.bbclass
+++ /dev/null
@@ -1,131 +0,0 @@
-BPV ?= "${PV}"
-
-DEPENDS += " \
- ruby-native \
-"
-RDEPENDS_${PN} += " \
- ruby \
-"
-
-def get_rubyversion(p):
- import re
- from os.path import isfile
- import subprocess
- found_version = "SOMETHING FAILED!"
-
- cmd = "%s/ruby" % p
-
- if not isfile(cmd):
- return found_version
-
- version = subprocess.Popen([cmd, "--version"], stdout=subprocess.PIPE).communicate()[0].decode("utf-8")
-
- r = re.compile("ruby ([0-9]+\.[0-9]+\.[0-9]+)*")
- m = r.match(version)
- if m:
- found_version = m.group(1)
-
- return found_version
-
-def get_rubygemslocation(p):
- import re
- from os.path import isfile
- import subprocess
- found_loc = "SOMETHING FAILED!"
-
- cmd = "%s/gem" % p
-
- if not isfile(cmd):
- return found_loc
-
- loc = subprocess.Popen([cmd, "env"], stdout=subprocess.PIPE).communicate()[0].decode("utf-8")
-
- r = re.compile(".*\- (/usr.*/ruby/gems/.*)")
- for line in loc.split('\n'):
- m = r.match(line)
- if m:
- found_loc = m.group(1)
- break
-
- return found_loc
-
-def get_rubygemsversion(p):
- import re
- from os.path import isfile
- import subprocess
- found_version = "SOMETHING FAILED!"
-
- cmd = "%s/gem" % p
-
- if not isfile(cmd):
- return found_version
-
- version = subprocess.Popen([cmd, "env", "gemdir"], stdout=subprocess.PIPE).communicate()[0].decode("utf-8")
-
- r = re.compile(".*([0-9]+\.[0-9]+\.[0-9]+)$")
- m = r.match(version)
- if m:
- found_version = m.group(1)
-
- return found_version
-
-RUBY_VERSION ?= "${@get_rubyversion("${STAGING_BINDIR_NATIVE}")}"
-RUBY_GEM_DIRECTORY ?= "${@get_rubygemslocation("${STAGING_BINDIR_NATIVE}")}"
-RUBY_GEM_VERSION ?= "${@get_rubygemsversion("${STAGING_BINDIR_NATIVE}")}"
-
-export GEM_HOME = "${STAGING_DIR_NATIVE}/usr/lib/ruby/gems/${RUBY_GEM_VERSION}"
-
-RUBY_BUILD_GEMS ?= "${BPN}.gemspec"
-RUBY_INSTALL_GEMS ?= "${BPN}-${BPV}.gem"
-
-RUBY_COMPILE_FLAGS ?= 'LANG="en_US.UTF-8" LC_ALL="en_US.UTF-8"'
-
-ruby_do_compile() {
- for gem in ${RUBY_BUILD_GEMS}; do
- ${RUBY_COMPILE_FLAGS} gem build $gem
- done
-}
-
-
-ruby_do_install() {
- for gem in ${RUBY_INSTALL_GEMS}; do
- gem install --ignore-dependencies --local --env-shebang --install-dir ${D}/${libdir}/ruby/gems/${RUBY_GEM_VERSION}/ $gem
- done
-
- # create symlink from the gems bin directory to /usr/bin
- for i in ${D}/${libdir}/ruby/gems/${RUBY_GEM_VERSION}/bin/*; do
- if [ -e "$i" ]; then
- if [ ! -d ${D}/${bindir} ]; then mkdir -p ${D}/${bindir}; fi
- b=`basename $i`
- ln -sf ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/bin/$b ${D}/${bindir}/$b
- fi
- done
-}
-
-EXPORT_FUNCTIONS do_compile do_install
-
-PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-dev"
-
-FILES_${PN}-dbg += " \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/.debug \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/*/.debug \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/*/*/.debug \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems/*/*/*/*/*/.debug \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions/*/*/.debug \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions/*/*/*/.debug \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions/*/*/*/*/.debug \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions/*/*/*/*/*/.debug \
- "
-
-FILES_${PN} += " \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/gems \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/cache \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/bin \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/specifications \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/build_info \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/extensions \
- "
-
-FILES_${PN}-doc += " \
- ${libdir}/ruby/gems/${RUBY_GEM_VERSION}/doc \
- "
diff --git a/meta-ruby/conf/layer.conf b/meta-ruby/conf/layer.conf
deleted file mode 100644
index b526a5d394..0000000000
--- a/meta-ruby/conf/layer.conf
+++ /dev/null
@@ -1,15 +0,0 @@
-# We have a conf and classes directory, append to BBPATH
-BBPATH .= ":${LAYERDIR}"
-
-# We have a recipes directory, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "ruby-layer"
-BBFILE_PATTERN_ruby-layer := "^${LAYERDIR}/"
-BBFILE_PRIORITY_ruby-layer = "7"
-
-# This should only be incremented on significant changes that will
-# cause compatibility issues with other layers
-LAYERVERSION_ruby-layer = "1"
-
-LAYERDEPENDS_ruby-layer = "core openembedded-layer"