aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ruby
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-11-17 11:13:16 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-18 12:39:50 +0100
commitb5341db1c245e581b25e2b7d5766ed2c1bbd17f7 (patch)
treea13eb6c215e0317504574d8869302813651374c3 /meta-ruby
parent00264bf4b3adad0cc2b083acbe23fdb3235c5874 (diff)
downloadmeta-openembedded-contrib-b5341db1c245e581b25e2b7d5766ed2c1bbd17f7.tar.gz
meta-openembedded-contrib-b5341db1c245e581b25e2b7d5766ed2c1bbd17f7.tar.bz2
meta-openembedded-contrib-b5341db1c245e581b25e2b7d5766ed2c1bbd17f7.zip
imsettings: Move from meta-ruby to meta-xfce
It depends on xfconf which is XFCE component, no one depends on imsettings in meta-ruby so move it close to its dependencies. Ideally, xfconf should be turned into PACKAGECONFIG and this recipe then moved to meta-oe since all kind of DE's can use it then. For now it frees meta-ruby from unnecessary dependency on xfce layer Change-Id: I6b5896b0db504fad49a9da5967d3493e27c627b0 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-ruby')
-rw-r--r--meta-ruby/conf/layer.conf2
-rw-r--r--meta-ruby/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch18
-rw-r--r--meta-ruby/recipes-extended/imsettings/imsettings/multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch21
-rw-r--r--meta-ruby/recipes-extended/imsettings/imsettings_1.6.8.bb30
4 files changed, 1 insertions, 70 deletions
diff --git a/meta-ruby/conf/layer.conf b/meta-ruby/conf/layer.conf
index b05345075a..b526a5d394 100644
--- a/meta-ruby/conf/layer.conf
+++ b/meta-ruby/conf/layer.conf
@@ -12,4 +12,4 @@ BBFILE_PRIORITY_ruby-layer = "7"
# cause compatibility issues with other layers
LAYERVERSION_ruby-layer = "1"
-LAYERDEPENDS_ruby-layer = "core openembedded-layer xfce-layer"
+LAYERDEPENDS_ruby-layer = "core openembedded-layer"
diff --git a/meta-ruby/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch b/meta-ruby/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch
deleted file mode 100644
index d42358d690..0000000000
--- a/meta-ruby/recipes-extended/imsettings/imsettings/gtk-is-required-by-notify.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-gtk+ is required by linnotify. So make sure gtk be linked before libnotify
-
-Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
-
-diff -Nurp imsettings-1.6.7.orig/configure.ac imsettings-1.6.7/configure.ac
---- imsettings-1.6.7.orig/configure.ac 2013-11-26 16:09:09.000000000 +0800
-+++ imsettings-1.6.7/configure.ac 2014-12-30 11:27:44.370003209 +0800
-@@ -93,8 +93,8 @@ PKG_CHECK_MODULES(LIBNOTIFY, libnotify,
- has_old_libnotify=yes
- PKG_CHECK_MODULES(GTK, gtk+-2.0 >= $GTK_REQUIRED)
- AC_DEFINE(HAS_OLD_LIBNOTIFY,, [Using older libnotify])
-- IMDAEMON_CFLAGS="$GTK_CFLAGS $LIBNOTIFY_OLD_CFLAGS"
-- IMDAEMON_LIBS="$GTK_LIBS $LIBNOTIFY_OLD_LIBS"],[
-+ IMDAEMON_CFLAGS="$LIBNOTIFY_OLD_CFLAGS $GTK_CFLAGS"
-+ IMDAEMON_LIBS="$LIBNOTIFY_OLD_LIBS $GTK_LIBS"],[
- has_old_libnotify=no
- IMDAEMON_CFLAGS="$LIBNOTIFY_CFLAGS"
- IMDAEMON_LIBS="$LIBNOTIFY_LIBS"])
diff --git a/meta-ruby/recipes-extended/imsettings/imsettings/multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch b/meta-ruby/recipes-extended/imsettings/imsettings/multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch
deleted file mode 100644
index 9e318474e4..0000000000
--- a/meta-ruby/recipes-extended/imsettings/imsettings/multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-multi-line ACLOCAL_AMFLAGS isn't supported by autoreconf.
-It will cause configure error as follow.
-
- aclocal: error: non-option arguments are not accepted: '\'.
-
-Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
-
-diff -Nurp imsettings-1.6.8.orig/Makefile.am imsettings-1.6.8/Makefile.am
---- imsettings-1.6.8.orig/Makefile.am 2013-02-08 11:33:59.000000000 +0900
-+++ imsettings-1.6.8/Makefile.am 2015-06-24 14:15:32.070000007 +0900
-@@ -1,9 +1,7 @@
- NULL =
- SUBDIRS = data imsettings imsettings-daemon backends utils po tests docs
-
--ACLOCAL_AMFLAGS = \
-- -I m4macros \
-- $(NULL)
-+ACLOCAL_AMFLAGS = -I m4macros $(NULL)
-
- CONFIGURE_DEPENDENCIES = \
- requires \
diff --git a/meta-ruby/recipes-extended/imsettings/imsettings_1.6.8.bb b/meta-ruby/recipes-extended/imsettings/imsettings_1.6.8.bb
deleted file mode 100644
index 699547dec1..0000000000
--- a/meta-ruby/recipes-extended/imsettings/imsettings_1.6.8.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-SUMMARY = "Delivery framework for general Input Method configuration"
-DESCRIPTION = "IMSettings is a framework that delivers Input Method \
-settings and applies the changes so they take effect \
-immediately without any need to restart applications \
-or the desktop. \
-This package contains the core DBus services and some utilities."
-HOMEPAGE = "http://code.google.com/p/imsettings/"
-SECTION = "Applications/System"
-
-inherit autotools gtk-doc
-
-SRC_URI = "https://bitbucket.org/tagoh/imsettings/downloads/${BPN}-${PV}.tar.bz2 \
- file://gtk-is-required-by-notify.patch \
- file://multi-line-ACLOCAL_AMFLAGS-isnot-supported-by-autoreconf.patch"
-
-SRC_URI[md5sum] = "c31429f1d60e36d7f811f871c75b6c41"
-SRC_URI[sha256sum] = "2620ffbf9a6dc842dbf994b4773d4fe355eb77076ccf33f726ba63f16c0d08ba"
-
-LICENSE = "LGPLv2+"
-LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
-
-EXTRA_OECONF = "--with-xinputsh=50-xinput.sh \
- --disable-static \
- "
-
-DEPENDS = "gtk+ gconf libnotify dbus-glib libgxim xfconf"
-
-RDEPENDS_${PN} += "bash"
-
-FILES_${PN} += "${datadir}/dbus-1/*"