aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ruby
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2014-09-23 13:44:24 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-09-26 05:42:53 +0200
commitfe63c201b19c1166eef281981bf9f4270cbc6ea9 (patch)
treef10e5c9b54515519c93d9885b95b808ac7fca7a6 /meta-ruby
parentda6908e1d30e214c99ea24ab5ce42b85934447e4 (diff)
downloadmeta-openembedded-contrib-fe63c201b19c1166eef281981bf9f4270cbc6ea9.tar.gz
meta-openembedded-contrib-fe63c201b19c1166eef281981bf9f4270cbc6ea9.tar.bz2
meta-openembedded-contrib-fe63c201b19c1166eef281981bf9f4270cbc6ea9.zip
ruby.inc: DEPEND on libyaml-native
Without this dependency we will see warnings when ever we use the ruby-native from the sysroot ...tmp/sysroots/x86_64-linux/usr/lib/ruby/yaml.rb:84:in `<top (required)>': It seems your ruby installation is missing psych (for YAML output). To eliminate this warning, please install libyaml and reinstall your ruby. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-ruby')
-rw-r--r--meta-ruby/recipes-devtools/ruby/ruby.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-ruby/recipes-devtools/ruby/ruby.inc b/meta-ruby/recipes-devtools/ruby/ruby.inc
index e679f27a21..409a320fdd 100644
--- a/meta-ruby/recipes-devtools/ruby/ruby.inc
+++ b/meta-ruby/recipes-devtools/ruby/ruby.inc
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "\
"
DEPENDS = "ruby-native zlib openssl tcl libyaml db gdbm readline"
-DEPENDS_class-native = ""
+DEPENDS_class-native = "libyaml-native"
INC_PR = "r1"