aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/meta-oe
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-06-10 21:46:50 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:06 +0200
commit365d5ec941347f54744b9f5fbb7b06cc3949e14a (patch)
tree322e21d7d6a98669598f40d51f89e4d8e048c273 /meta-systemd/meta-oe
parenta55a93180733f769d676d9e66f74bf10d5da6ff0 (diff)
downloadmeta-openembedded-contrib-365d5ec941347f54744b9f5fbb7b06cc3949e14a.tar.gz
gateone: move systemd support to meta-systemd
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-systemd/meta-oe')
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service10
-rw-r--r--meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend11
2 files changed, 21 insertions, 0 deletions
diff --git a/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
new file mode 100644
index 0000000000..7ff60020a0
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone/gateone.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=GateOne daemon
+ConditionPathExists=|/var/lib/gateone
+
+[Service]
+WorkingDirectory=/var/lib/gateone
+ExecStart=/usr/bin/python gateone.py
+
+[Install]
+WantedBy=multi-user.target
diff --git a/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend
new file mode 100644
index 0000000000..dd5fea1a96
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-connectivity/gateone/gateone_git.bbappend
@@ -0,0 +1,11 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PRINC := "${@int(PRINC) + 1}"
+
+inherit systemd
+
+SRC_URI += "file://gateone.service"
+
+NATIVE_SYSTEMD_SUPPORT = "1"
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE = "gateone.service"