aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/recipes-core/systemd/systemd-compat-units.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-01-24 23:37:36 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-02-01 17:44:21 +0100
commit52bb450cc8c98626228ebd8f1f73bfa98afe97d7 (patch)
tree74edbf803cc23e9eccca210ceef983616fef4d4c /meta-systemd/recipes-core/systemd/systemd-compat-units.bb
parentd6d009b2625d6bcc7152d700fce2fdfecd3e0bd7 (diff)
downloadmeta-openembedded-contrib-52bb450cc8c98626228ebd8f1f73bfa98afe97d7.tar.gz
systemd: remove core recipes - they migrated to oe-core
oe-core moved to systemd 197 so no package feeds should break Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-systemd/recipes-core/systemd/systemd-compat-units.bb')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd-compat-units.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd-compat-units.bb b/meta-systemd/recipes-core/systemd/systemd-compat-units.bb
deleted file mode 100644
index 6b6b4dda98..0000000000
--- a/meta-systemd/recipes-core/systemd/systemd-compat-units.bb
+++ /dev/null
@@ -1,59 +0,0 @@
-DESCRIPTION = "Units to make systemd work better with existing sysvinit scripts"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-
-PR = "r18"
-
-inherit allarch
-
-SRC_URI = "file://*.service"
-
-do_install() {
- install -d ${D}${systemd_unitdir}/system/basic.target.wants
- install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
- install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_unitdir}/system
- ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/basic.target.wants/
- ln -sf ../run-postinsts.service ${D}${systemd_unitdir}/system/sysinit.target.wants/
-
- install -m 0644 ${WORKDIR}/machineid.service ${D}${systemd_unitdir}/system
- ln -sf ../machineid.service ${D}${systemd_unitdir}/system/sysinit.target.wants/
- ln -sf ../machineid.service ${D}${systemd_unitdir}/system/basic.target.wants/
-
- # hack to make old style sysvinit postinsts succeed
- install -d ${D}${bindir}
- echo "echo 1" > ${D}${bindir}/runlevel
- chmod 0755 ${D}${bindir}/runlevel
-}
-
-SYSTEMD_DISABLED_SYSV_SERVICES = " \
- busybox-udhcpc \
- dnsmasq \
- hwclock \
- networking \
- syslog \
- syslog.busybox \
-"
-
-pkg_postinst_${PN} () {
-cd $D${sysconfdir}/init.d
-
-echo "Disabling the following sysv scripts: "
-
-OPTS=""
-
-if [ -n "$D" ]; then
- OPTS="--root=$D"
-fi
-
-for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do
- if [ \( -e $i -o $i.sh \) -a ! -e $D${sysconfdir}/systemd/system/$i.service ] ; then
- echo -n "$i: " ; systemctl ${OPTS} mask $i.service
- fi
-done ; echo
-}
-
-FILES_${PN} = "${systemd_unitdir}/system ${bindir}"
-RDPEPENDS_${PN} = "systemd"
-
-