aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/recipes-core/systemd/systemd
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-04 20:05:30 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-08-08 09:02:30 +0200
commit980b338fb5100ff4c779335a86f3d9450ea8c54a (patch)
tree1d6db1881f20819cbee0e8dcf9de37ad55478bd0 /meta-systemd/recipes-core/systemd/systemd
parent3ce8db6d187b864fa59206d4efa93b8f952b534e (diff)
downloadmeta-openembedded-contrib-980b338fb5100ff4c779335a86f3d9450ea8c54a.tar.gz
systemd: Upgrade to 187 tag
Dont inherit vala not needed anymore Fix build for ppc64 Consider /lib64 and /usr/lib64 Some 64bit architectures chose lib64 instead of lib for default library dirnames. So we dig this from metadata vars base_libdir and libdir instead of hardcoding 'lib' ppc64 in OE uses lib64 for default libdir and this leaves lot of udev/systemd files unpackaged since 'lib' was hardcoded Additionally use --split-usr option since in OE-Core now we want to treat /usr mounted sepatately. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd/recipes-core/systemd/systemd')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch94
1 files changed, 94 insertions, 0 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch b/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch
new file mode 100644
index 0000000000..2167216844
--- /dev/null
+++ b/meta-systemd/recipes-core/systemd/systemd/use-rootlibdir.patch
@@ -0,0 +1,94 @@
+Upstream-Status: Undecided
+
+This patch removes some of hardcoded references to /lib
+and /usr/lib since on some architectures it should be
+/lib64 and /usr/lib64 atleast in OE
+
+I am not sure about the intention of hardcoded values
+thats why status is undecided
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Index: git/Makefile.am
+===================================================================
+--- git.orig/Makefile.am 2012-07-22 16:20:38.424405916 -0700
++++ git/Makefile.am 2012-07-22 16:23:21.232406621 -0700
+@@ -61,23 +61,23 @@
+
+ # Our own, non-special dirs
+ pkgsysconfdir=$(sysconfdir)/systemd
+-userunitdir=$(prefix)/lib/systemd/user
+-tmpfilesdir=$(prefix)/lib/tmpfiles.d
+-sysctldir=$(prefix)/lib/sysctl.d
+-usergeneratordir=$(prefix)/lib/systemd/user-generators
++userunitdir=$(prefix)/$(rootlibdir)/systemd/user
++tmpfilesdir=$(prefix)/$(rootlibdir)/tmpfiles.d
++sysctldir=$(prefix)/$(rootlibdir)/sysctl.d
++usergeneratordir=$(prefix)/$(rootlibdir)/systemd/user-generators
+ pkgincludedir=$(includedir)/systemd
+ systemgeneratordir=$(rootlibexecdir)/system-generators
+ systemshutdowndir=$(rootlibexecdir)/system-shutdown
+ systemsleepdir=$(rootlibexecdir)/system-sleep
+-systemunitdir=$(rootprefix)/lib/systemd/system
+-udevlibexecdir=$(rootprefix)/lib/udev
++systemunitdir=$(rootprefix)/$(rootlibdir)/systemd/system
++udevlibexecdir=$(rootprefix)/$(rootlibdir)/udev
+ udevhomedir = $(udevlibexecdir)
+ udevrulesdir = $(udevlibexecdir)/rules.d
+
+ # And these are the special ones for /
+ rootprefix=@rootprefix@
+ rootbindir=$(rootprefix)/bin
+-rootlibexecdir=$(rootprefix)/lib/systemd
++rootlibexecdir=$(rootprefix)/$(rootlibdir)/systemd
+
+ CLEANFILES =
+ EXTRA_DIST =
+@@ -126,7 +126,7 @@
+ -DSYSTEMD_STDIO_BRIDGE_BINARY_PATH=\"$(bindir)/systemd-stdio-bridge\" \
+ -DROOTPREFIX=\"$(rootprefix)\" \
+ -DRUNTIME_DIR=\"/run\" \
+- -DRANDOM_SEED=\"$(localstatedir)/lib/random-seed\" \
++ -DRANDOM_SEED=\"$(localstatedir)/$(rootlibdir)/random-seed\" \
+ -DSYSTEMD_CRYPTSETUP_PATH=\"$(rootlibexecdir)/systemd-cryptsetup\" \
+ -DSYSTEM_GENERATOR_PATH=\"$(systemgeneratordir)\" \
+ -DUSER_GENERATOR_PATH=\"$(usergeneratordir)\" \
+@@ -2535,7 +2535,7 @@
+
+ binfmt-install-data-hook:
+ $(MKDIR_P) -m 0755 \
+- $(DESTDIR)$(prefix)/lib/binfmt.d \
++ $(DESTDIR)$(prefix)/$(rootlibdir)/binfmt.d \
+ $(DESTDIR)$(sysconfdir)/binfmt.d \
+ $(DESTDIR)$(systemunitdir)/sysinit.target.wants
+ ( cd $(DESTDIR)$(systemunitdir)/sysinit.target.wants && \
+@@ -3165,7 +3165,7 @@
+ logind-install-data-hook:
+ $(MKDIR_P) -m 0755 \
+ $(DESTDIR)$(systemunitdir)/multi-user.target.wants \
+- $(DESTDIR)$(localstatedir)/lib/systemd
++ $(DESTDIR)$(localstatedir)/$(rootlibdir)/systemd
+ ( cd $(DESTDIR)$(systemunitdir) && \
+ rm -f dbus-org.freedesktop.login1.service && \
+ $(LN_S) systemd-logind.service dbus-org.freedesktop.login1.service)
+@@ -3284,7 +3284,7 @@
+ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
+ -e 's,@PACKAGE_NAME\@,$(PACKAGE_NAME),g' \
+ -e 's,@PACKAGE_URL\@,$(PACKAGE_URL),g' \
+- -e 's,@RANDOM_SEED\@,$(localstatedir)/lib/random-seed,g' \
++ -e 's,@RANDOM_SEED\@,$(localstatedir)/$(rootlibdir)/random-seed,g' \
+ -e 's,@prefix\@,$(prefix),g' \
+ -e 's,@exec_prefix\@,$(exec_prefix),g' \
+ -e 's,@libdir\@,$(libdir),g' \
+@@ -3407,9 +3407,9 @@
+ $(MKDIR_P) -m 0755 \
+ $(DESTDIR)$(tmpfilesdir) \
+ $(DESTDIR)$(sysconfdir)/tmpfiles.d \
+- $(DESTDIR)$(prefix)/lib/modules-load.d \
++ $(DESTDIR)$(prefix)/$(rootlibdir)/modules-load.d \
+ $(DESTDIR)$(sysconfdir)/modules-load.d \
+- $(DESTDIR)$(prefix)/lib/sysctl.d \
++ $(DESTDIR)$(prefix)/$(rootlibdir)/sysctl.d \
+ $(DESTDIR)$(sysconfdir)/sysctl.d \
+ $(DESTDIR)$(systemshutdowndir) \
+ $(DESTDIR)$(systemsleepdir) \