aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/recipes-core/systemd/systemd_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-08-04 20:05:33 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-08-08 09:02:51 +0200
commitada707b4e1e0959acd292577c0a4f423a03e308c (patch)
tree22110999fdda29622ec024e110aec831319c5071 /meta-systemd/recipes-core/systemd/systemd_git.bb
parent6fd1caa623563f728d87434f5684cf1d3c9b6c53 (diff)
downloadmeta-openembedded-contrib-ada707b4e1e0959acd292577c0a4f423a03e308c.tar.gz
systemd: Use cross cpp
While building for non x86 arch (ppc) found that build was using host's cpp which was not generating exact syscall list for ppc since it was using the include files from host With this patch will use $(CPP) instead of hardcoding cpp in makefile.am and then set CPP properly in recipe Fixes build failures on cross builds Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd/recipes-core/systemd/systemd_git.bb')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd_git.bb b/meta-systemd/recipes-core/systemd/systemd_git.bb
index 5d1c28b319..b1cc9c3941 100644
--- a/meta-systemd/recipes-core/systemd/systemd_git.bb
+++ b/meta-systemd/recipes-core/systemd/systemd_git.bb
@@ -27,6 +27,7 @@ SRCREV = "3fd89536883ea9e24e69f28de0d11cd7cffb42ce"
SRC_URI = "git://anongit.freedesktop.org/systemd/systemd;protocol=git \
file://use-rootlibdir.patch \
+ file://use-cross-cpp.patch \
file://gtk-doc.make \
file://touchscreen.rules \
file://modprobe.rules \
@@ -62,6 +63,7 @@ EXTRA_OECONF = " --with-distro=${SYSTEMDDISTRO} \
# There's no docbook-xsl-native, so for the xsltproc check to false
do_configure_prepend() {
+ export CPP="${HOST_PREFIX}cpp ${TOOLCHAIN_OPTIONS} ${HOST_CC_ARCH}"
sed -i /xsltproc/d configure.ac
cp ${WORKDIR}/gtk-doc.make ${S}/docs/