aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2012-07-11 13:53:25 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-07-16 09:39:06 +0200
commit36aa9a4fc012db3eeb9cb34841e7988315176496 (patch)
treef94abc8a001058d3520b680501ecef098b61fa9f /meta-systemd
parent14a5f1174c96f25c7dffc17902043f9be0e716f6 (diff)
downloadmeta-openembedded-contrib-36aa9a4fc012db3eeb9cb34841e7988315176496.tar.gz
lighttpd: move systemd support to meta-systemd
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service13
-rw-r--r--meta-systemd/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.31.bbappend10
2 files changed, 23 insertions, 0 deletions
diff --git a/meta-systemd/meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service b/meta-systemd/meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service
new file mode 100644
index 0000000000..f4564f3f7d
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-extended/lighttpd/lighttpd/lighttpd.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Lightning Fast Webserver With Light System Requirements
+After=syslog.target
+
+[Service]
+Type=oneshot
+EnvironmentFile=-/etc/sysconfig/lighttpd
+ExecStart=/usr/sbin/lighttpd -D -f /etc/lighttpd.conf
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/meta-systemd/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.31.bbappend b/meta-systemd/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.31.bbappend
new file mode 100644
index 0000000000..b016bdc2fb
--- /dev/null
+++ b/meta-systemd/meta-oe/recipes-extended/lighttpd/lighttpd_1.4.31.bbappend
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+PRINC := "${@int(PRINC) + 2}"
+
+inherit systemd
+
+SRC_URI += "file://lighttpd.service"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE_${PN} = "lighttpd.service"