aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2012-08-06 22:26:11 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2012-08-08 09:02:05 +0200
commit3ce8db6d187b864fa59206d4efa93b8f952b534e (patch)
tree089afb4dca67c2f81950ac5387a280277764f516 /meta-systemd
parente32c470d32809be3d0249097214881021532fb2c (diff)
downloadmeta-openembedded-contrib-3ce8db6d187b864fa59206d4efa93b8f952b534e.tar.gz
systemd-systemctl-native: extend systemctl wrapper to support mask action
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/recipes-core/systemd/systemd-systemctl-native.bb2
-rwxr-xr-xmeta-systemd/recipes-core/systemd/systemd-systemctl-native/systemctl18
2 files changed, 19 insertions, 1 deletions
diff --git a/meta-systemd/recipes-core/systemd/systemd-systemctl-native.bb b/meta-systemd/recipes-core/systemd/systemd-systemctl-native.bb
index 7ca77ae18a..5f23e988eb 100644
--- a/meta-systemd/recipes-core/systemd/systemd-systemctl-native.bb
+++ b/meta-systemd/recipes-core/systemd/systemd-systemctl-native.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Wrapper to enable of systemd services"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r3"
+PR = "r4"
inherit native
diff --git a/meta-systemd/recipes-core/systemd/systemd-systemctl-native/systemctl b/meta-systemd/recipes-core/systemd/systemd-systemctl-native/systemctl
index ff9e6a7512..a5bd77085b 100755
--- a/meta-systemd/recipes-core/systemd/systemd-systemctl-native/systemctl
+++ b/meta-systemd/recipes-core/systemd/systemd-systemctl-native/systemctl
@@ -25,6 +25,14 @@ while [ $# != 0 ]; do
cmd_args="1"
shift
;;
+ mask)
+ shift
+
+ action="$opt"
+ services="$1"
+ cmd_args="1"
+ shift
+ ;;
--root=*)
ROOT=${opt##--root=}
cmd_args="0"
@@ -43,6 +51,16 @@ while [ $# != 0 ]; do
done
for service in $services; do
+ if [ "$action" = "mask" ]; then
+ if [ ! -d $ROOT/etc/systemd/system/ ]; then
+ mkdir -p $ROOT/etc/systemd/system/
+ fi
+ cmd="ln -s /dev/null $ROOT/etc/systemd/system/$service"
+ echo "$cmd"
+ $cmd
+ exit 0
+ fi
+
echo "Try to find location of $service..."
# find service file
for p in $ROOT/etc/systemd/system \