aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2013-10-26 01:59:26 -0400
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-10-28 16:31:55 +0000
commitb71a6567f84e13593aec6f3a6ad4f9e9e0c15c3f (patch)
tree23422e7b67d746a4ba7827d5b018ae61259342b6 /meta-webserver
parent603c635feb211e7c092a39e73784303859bfdd47 (diff)
downloadmeta-openembedded-contrib-b71a6567f84e13593aec6f3a6ad4f9e9e0c15c3f.tar.gz
cherokee: fix the installed but not shipped issue
We will get the following ERROR/WARN if we enable the installed-vs-shipped check in QA: ERROR: QA Issue: cherokee: Files/directories were installed but not shipped /srv /srv/www /srv/www/htdocs /srv/www/htdocs/index.html /srv/www/htdocs/images /srv/www/htdocs/images/cherokee-logo.png /srv/www/htdocs/images/default-bg.png /srv/www/htdocs/images/favicon.ico /srv/www/htdocs/images/powered_by_cherokee.png I think that we can pack these files into cherokee just like what apache2 does. Fedora 17 also packs them Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
index 2014ea16cb..2a732d5ecf 100644
--- a/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
+++ b/meta-webserver/recipes-httpd/cherokee/cherokee_1.2.98.bb
@@ -25,6 +25,7 @@ PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
EXTRA_OECONF = "--disable-static \
--disable-nls \
${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \
+ --with-wwwroot=${localstatedir}/www/cherokee \
"
do_install_append () {
@@ -48,6 +49,9 @@ FILES_libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}"
FILES_libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}"
FILES_libcherokee-base = "${libdir}/libcherokee-base${SOLIBS}"
+# Pack the htdocs
+FILES_${PN} += "${localstatedir}/www/cherokee"
+
CONFFILES_${PN} = " \
${sysconfdir}/cherokee/cherokee.conf \
${sysconfdir}/init.d/cherokee \