aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-10-07 11:55:20 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-09 11:09:23 +0200
commit0cd6b15d729c7f4b17ac02180e7c5462b91ed9e4 (patch)
treeabd3c30fe4a23fb9abc1ac6d6708d6135869acbe /meta-webserver
parent6d182b316f366e3491ee50ccd021eb7a79189136 (diff)
downloadmeta-openembedded-contrib-0cd6b15d729c7f4b17ac02180e7c5462b91ed9e4.tar.gz
modphp: fix default php.ini & add PACKAGECONFIG
* Add "mysql" PACKAGECONFIG option * Add "pgsql" PACKAGECONFIG option (untested) * Use the correct template php.ini filename so that we actually get some content in the default file Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'meta-webserver')
-rw-r--r--meta-webserver/recipes-php/modphp/modphp5.inc34
-rw-r--r--meta-webserver/recipes-php/modphp/modphp_5.3.14.bb2
2 files changed, 18 insertions, 18 deletions
diff --git a/meta-webserver/recipes-php/modphp/modphp5.inc b/meta-webserver/recipes-php/modphp/modphp5.inc
index 82b5ce1a64..344eb31d98 100644
--- a/meta-webserver/recipes-php/modphp/modphp5.inc
+++ b/meta-webserver/recipes-php/modphp/modphp5.inc
@@ -20,27 +20,27 @@ CFLAGS += " -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -I${STAGING_INCDIR}/apache2"
EXTRA_OECONF = "--with-apxs2=${STAGING_BINDIR_CROSS}/apxs \
--enable-maintainer-zts \
--without-mysql \
- --enable-force-cgi-redirect \
- --disable-cgi \
- --disable-cli \
- --disable-pdo \
- --without-pear \
- --without-iconv \
- --disable-ipv6 \
- --disable-xml \
- --disable-xmlreader \
- --disable-xmlwriter \
- --disable-simplexml \
- --disable-libxml \
- --disable-dom \
+ --enable-force-cgi-redirect \
+ --disable-cgi \
+ --disable-cli \
+ --disable-pdo \
+ --without-pear \
+ --without-iconv \
+ --disable-ipv6 \
+ --disable-xml \
+ --disable-xmlreader \
+ --disable-xmlwriter \
+ --disable-simplexml \
+ --disable-libxml \
+ --disable-dom \
--disable-rpath \
--libdir=${libdir}/php5 \
--with-zlib --with-zlib-dir=${STAGING_DIR_TARGET}${exec_prefix} \
--with-config-file-path=${sysconfdir}/php/apache2-php5"
-# to get postgres support, add it to the DEPENDS above
-# and uncomment this line. similar for mysql
-#EXTRA_OECONF += " --with-pgsql=${STAGING_DIR_HOST}${layout_exec_prefix}"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[mysql] = "--with-mysqli=${STAGING_BINDIR_CROSS}/mysql_config,--without-mysqli,mysql5"
+PACKAGECONFIG[pgsql] = "--with-pgsql=${STAGING_DIR_TARGET}${exec_prefix},--without-pgsql,mysql5"
acpaths = ""
@@ -60,7 +60,7 @@ do_install () {
install -d ${D}${sysconfdir}/php/apache2-php5
install -m 755 libs/libphp5.so ${D}${libdir}/apache2/modules
install -m 644 ${WORKDIR}/70_mod_php5.conf ${D}${sysconfdir}/apache2/modules.d
- cat ${S}/php.ini-dist | \
+ cat ${S}/php.ini-production | \
sed -e 's,extension_dir = \"\./\",extension_dir = \"/usr/lib/extensions\",' \
> ${D}${sysconfdir}/php/apache2-php5/php.ini
diff --git a/meta-webserver/recipes-php/modphp/modphp_5.3.14.bb b/meta-webserver/recipes-php/modphp/modphp_5.3.14.bb
index b6a51267b7..707f5f90bf 100644
--- a/meta-webserver/recipes-php/modphp/modphp_5.3.14.bb
+++ b/meta-webserver/recipes-php/modphp/modphp_5.3.14.bb
@@ -1,5 +1,5 @@
include modphp5.inc
-PR = "r0"
+PR = "r1"
SRC_URI[md5sum] = "7caac4f71e2f21426c11ac153e538392"
SRC_URI[sha256sum] = "c8075b6e83c5db0d26cc8426a7456856421089a76c963813b1fcac3ced041cb3"