aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-panel-plugins
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-06-14 11:44:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-06-20 12:28:00 +0200
commitcc08f7d436c1d3e68e7144c59a5c4664ffa4176d (patch)
treeacd981a0160e932106eef487d23bc9b3ef69ff0e /meta-xfce/recipes-panel-plugins
parent96f7caf0608cc1d407f8d9ec1732e7290ab8e5ea (diff)
downloadmeta-openembedded-contrib-cc08f7d436c1d3e68e7144c59a5c4664ffa4176d.tar.gz
xfce4-genmon-plugin: Allow timer period to be set at 250ms resolution
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce/recipes-panel-plugins')
-rw-r--r--meta-xfce/recipes-panel-plugins/genmon/files/0001-Allow-timer-period-to-be-set-at-250ms-resolution.-Pa.patch36
-rw-r--r--meta-xfce/recipes-panel-plugins/genmon/xfce4-genmon-plugin_3.4.0.bb2
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-xfce/recipes-panel-plugins/genmon/files/0001-Allow-timer-period-to-be-set-at-250ms-resolution.-Pa.patch b/meta-xfce/recipes-panel-plugins/genmon/files/0001-Allow-timer-period-to-be-set-at-250ms-resolution.-Pa.patch
new file mode 100644
index 0000000000..28c0eb1443
--- /dev/null
+++ b/meta-xfce/recipes-panel-plugins/genmon/files/0001-Allow-timer-period-to-be-set-at-250ms-resolution.-Pa.patch
@@ -0,0 +1,36 @@
+From 2d5fa307827a7b32af4f7b2ae0604f943e3a6e99 Mon Sep 17 00:00:00 2001
+From: John Lindgren <john.lindgren@aol.com>
+Date: Tue, 21 Aug 2012 19:33:45 -0400
+Subject: [PATCH] Allow timer period to be set at 250ms resolution. Patch
+ from Miguel Guedes. Closes: #9102.
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Applied [1]
+
+[1] http://git.xfce.org/panel-plugins/xfce4-genmon-plugin/commit/?id=2d5fa307827a7b32af4f7b2ae0604f943e3a6e99
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ panel-plugin/config_gui.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/panel-plugin/config_gui.c b/panel-plugin/config_gui.c
+index a4c891d..90e55c1 100644
+--- a/panel-plugin/config_gui.c
++++ b/panel-plugin/config_gui.c
+@@ -106,8 +106,8 @@ int genmon_CreateConfigGUI (GtkWidget *vbox1,
+ gtk_widget_show (alignment1);
+ gtk_container_add (GTK_CONTAINER (eventbox1), alignment1);
+
+- wSc_Period_adj = gtk_adjustment_new (15, 1, 60*60*24, 1, 1, 0);
+- wSc_Period = gtk_spin_button_new (GTK_ADJUSTMENT (wSc_Period_adj), 1, 0);
++ wSc_Period_adj = gtk_adjustment_new (15, .25, 60*60*24, .25, 1, 0);
++ wSc_Period = gtk_spin_button_new (GTK_ADJUSTMENT (wSc_Period_adj), .25, 2);
+ gtk_widget_show (wSc_Period);
+ gtk_container_add (GTK_CONTAINER (alignment1), wSc_Period);
+ gtk_tooltips_set_tip (tooltips, wSc_Period,
+--
+1.7.6.5
+
diff --git a/meta-xfce/recipes-panel-plugins/genmon/xfce4-genmon-plugin_3.4.0.bb b/meta-xfce/recipes-panel-plugins/genmon/xfce4-genmon-plugin_3.4.0.bb
index e5ef85fb51..a13db62a3c 100644
--- a/meta-xfce/recipes-panel-plugins/genmon/xfce4-genmon-plugin_3.4.0.bb
+++ b/meta-xfce/recipes-panel-plugins/genmon/xfce4-genmon-plugin_3.4.0.bb
@@ -5,6 +5,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=68ad62c64cc6c620126241fd429e68fe"
inherit xfce-panel-plugin
+SRC_URI += "file://0001-Allow-timer-period-to-be-set-at-250ms-resolution.-Pa.patch"
+
SRC_URI[md5sum] = "24108b339bb040ed360266f53a245224"
SRC_URI[sha256sum] = "b0a5337b49c85623dc89f3c9e47c7374b1d466af2418033d2d6dfc57a9790387"