aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-10-31 23:10:48 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-22 13:59:42 +0100
commit794acac89d12aceb181d17d7e3ede9b5e7bab6c8 (patch)
tree37f1ca54ec6c0d9f5c04d5b4122091d42446a4a3 /meta-xfce/recipes-xfce
parent5e4fd050be4be50fd26dd1c4c8ff83973a51e684 (diff)
downloadmeta-openembedded-contrib-794acac89d12aceb181d17d7e3ede9b5e7bab6c8.tar.gz
xfce4-panel: do not display desktop icon when no window is opened
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce')
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch60
-rw-r--r--meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb1
2 files changed, 61 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch b/meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
new file mode 100644
index 0000000000..b2d960c003
--- /dev/null
+++ b/meta-xfce/recipes-xfce/xfce4-panel/files/0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch
@@ -0,0 +1,60 @@
+From 0651f228cef01a6c3e4758a991cace1cd7721031 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Mon, 24 Sep 2012 09:57:46 +0200
+Subject: [PATCH] windowmenu: do not display desktop icon when no window is
+ active
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+* desktop icon is of no use
+* desktop icon confuses when using showdesktop plugin
+
+Upstream-Status: Pending
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ plugins/windowmenu/windowmenu.c | 12 ++++++------
+ 1 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/plugins/windowmenu/windowmenu.c b/plugins/windowmenu/windowmenu.c
+index c96123a..9404021 100644
+--- a/plugins/windowmenu/windowmenu.c
++++ b/plugins/windowmenu/windowmenu.c
+@@ -256,7 +256,7 @@ window_menu_plugin_init (WindowMenuPlugin *plugin)
+ g_signal_connect (G_OBJECT (plugin->button), "toggled",
+ G_CALLBACK (window_menu_plugin_menu), plugin);
+
+- plugin->icon = xfce_panel_image_new_from_source ("user-desktop");
++ plugin->icon = xfce_panel_image_new_from_source (NULL);
+ gtk_container_add (GTK_CONTAINER (plugin->button), plugin->icon);
+ gtk_widget_show (plugin->icon);
+ }
+@@ -634,7 +634,7 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
+ /* skip 'fake' windows */
+ type = wnck_window_get_window_type (window);
+ if (type == WNCK_WINDOW_DESKTOP || type == WNCK_WINDOW_DOCK)
+- goto show_desktop_icon;
++ goto show_no_icon;
+
+ /* get the window icon and set the tooltip */
+ gtk_widget_set_tooltip_text (GTK_WIDGET (icon),
+@@ -648,11 +648,11 @@ window_menu_plugin_active_window_changed (WnckScreen *screen,
+ }
+ else
+ {
+- show_desktop_icon:
++ show_no_icon:
+
+- /* desktop is shown right now */
+- xfce_panel_image_set_from_source (icon, "user-desktop");
+- gtk_widget_set_tooltip_text (GTK_WIDGET (icon), _("Desktop"));
++ /* no icon is shown right now */
++ xfce_panel_image_set_from_source (icon, NULL);
++ gtk_widget_set_tooltip_text (GTK_WIDGET (icon), _("No Windows"));
+ }
+ }
+ }
+--
+1.7.6.5
+
diff --git a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb
index 6a2b944be9..4148d9af4c 100644
--- a/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb
+++ b/meta-xfce/recipes-xfce/xfce4-panel/xfce4-panel_4.12.0.bb
@@ -11,6 +11,7 @@ SRC_URI[sha256sum] = "30920fc2e2fc26279a82b5261a155c2cc15ab2aa1ced2275684a6ff826
SRC_URI += " \
file://0001-Fix-compiler-warning-in-clock-plugin-about-shadowed-.patch \
file://0002-clock-time-make-change-of-system-s-timezone-change-t.patch \
+ file://0003-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
"
EXTRA_OECONF += "--enable-gtk3"