aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-08-14 22:04:34 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-22 15:49:23 +0200
commit9e78e4b521460cd80a1dea4f0d14865a8e06eecd (patch)
tree2683a28325786c1887f91577003877eb0a1b7e9b /meta-xfce/recipes-xfce
parentb415e2a372b555a3264359345e6aa52c10c9e1d7 (diff)
downloadmeta-openembedded-contrib-9e78e4b521460cd80a1dea4f0d14865a8e06eecd.tar.gz
thunar-volman: Fix build with clang
clang poins a void return for a boolean function | ../../thunar-volman-0.8.1/thunar-volman/tvm-block-device.c:717:3: error: non-void function 'tvm_block_device_mount' should return a value [-Wreturn-type] | g_return_if_fail (context != NULL); Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce')
-rw-r--r--meta-xfce/recipes-xfce/thunar-volman/thunar-volman/0001-Fix-return-with-no-value-in-function-returning-non-v.patch26
-rw-r--r--meta-xfce/recipes-xfce/thunar-volman/thunar-volman_0.8.1.bb1
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-xfce/recipes-xfce/thunar-volman/thunar-volman/0001-Fix-return-with-no-value-in-function-returning-non-v.patch b/meta-xfce/recipes-xfce/thunar-volman/thunar-volman/0001-Fix-return-with-no-value-in-function-returning-non-v.patch
new file mode 100644
index 0000000000..7233ea7ba6
--- /dev/null
+++ b/meta-xfce/recipes-xfce/thunar-volman/thunar-volman/0001-Fix-return-with-no-value-in-function-returning-non-v.patch
@@ -0,0 +1,26 @@
+From 2e295e9ce8f7f60a271adf004588b0d8db88db09 Mon Sep 17 00:00:00 2001
+From: Matt Thirtytwo <matt.59491@gmail.com>
+Date: Sat, 7 Mar 2015 22:50:32 +0100
+Subject: [PATCH] Fix return with no value in function returning non-void (bug
+ #11656)
+
+---
+ thunar-volman/tvm-block-device.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/thunar-volman/tvm-block-device.c b/thunar-volman/tvm-block-device.c
+index da31efa..edb6cad 100644
+--- a/thunar-volman/tvm-block-device.c
++++ b/thunar-volman/tvm-block-device.c
+@@ -714,7 +714,7 @@ tvm_block_device_mount (TvmContext *context)
+ GMountOperation *mount_operation;
+ GVolume *volume;
+
+- g_return_if_fail (context != NULL);
++ g_return_val_if_fail ((context != NULL), FALSE);
+
+ /* determine the GVolume corresponding to the udev device */
+ volume =
+--
+1.9.0
+
diff --git a/meta-xfce/recipes-xfce/thunar-volman/thunar-volman_0.8.1.bb b/meta-xfce/recipes-xfce/thunar-volman/thunar-volman_0.8.1.bb
index 08e6f5be2b..44e3777fa2 100644
--- a/meta-xfce/recipes-xfce/thunar-volman/thunar-volman_0.8.1.bb
+++ b/meta-xfce/recipes-xfce/thunar-volman/thunar-volman_0.8.1.bb
@@ -6,6 +6,7 @@ DEPENDS = "exo glib-2.0 gtk+ libxfce4ui libxfce4util xfconf libnotify libgudev"
inherit xfce
+SRC_URI += "file://0001-Fix-return-with-no-value-in-function-returning-non-v.patch"
SRC_URI[md5sum] = "65ab6e05b2e808d1dcc8d36683a59b7e"
SRC_URI[sha256sum] = "5a08bb5ce32c296a64dfbdb2406d4e45a208b2c91e4efa831dc28f1d6c2ac2bd"