aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2013-04-02 22:00:16 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-04-04 08:14:22 +0200
commit3c1619bc5a6dc42acca4a89db9f162b5505cedb8 (patch)
treeb7096ec7c262629a69e25c36357d17974e54facb /meta-xfce/recipes-xfce
parent7ea47c2cfac97a4e2df7631b4517af33557980e8 (diff)
downloadmeta-openembedded-contrib-3c1619bc5a6dc42acca4a89db9f162b5505cedb8.tar.gz
exo: add native build
The native build creates exo-csource only. exo-csource converts glade-files into c-header files. When building xfce projects from git repo, exo-csource is required (tarballs have the glade-headers included). Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-xfce/recipes-xfce')
-rw-r--r--meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch80
-rw-r--r--meta-xfce/recipes-xfce/exo/exo_0.10.2.bb9
2 files changed, 88 insertions, 1 deletions
diff --git a/meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch b/meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch
new file mode 100644
index 0000000000..84b2370967
--- /dev/null
+++ b/meta-xfce/recipes-xfce/exo/exo/reduce-build-to-exo-csource-only.patch
@@ -0,0 +1,80 @@
+From e710d8d4a3e3480416826c70d56ea3d2598a77e4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Thu, 28 Mar 2013 23:41:03 +0100
+Subject: [PATCH] reduce build to exo-csource only
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+exo-csource creates c-header files from glade resource output files. When
+building xfce-packages from git instead of tarball this exo-csource-native is
+required.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ Makefile.am | 10 +---------
+ configure.ac | 20 --------------------
+ 2 files changed, 1 insertions(+), 29 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index c2e3fff..79b0931 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,13 +1,5 @@
+ SUBDIRS = \
+- exo \
+- exo-csource \
+- exo-desktop-item-edit \
+- exo-helper \
+- exo-open \
+- docs \
+- icons \
+- pixmaps \
+- po
++ exo-csource
+
+ AUTOMAKE_OPTIONS = \
+ 1.9 \
+diff --git a/configure.ac b/configure.ac
+index efcd62e..aac2495 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -110,15 +110,6 @@ AC_PROG_CC()
+ AM_PROG_CC_C_O()
+ AC_PROG_INSTALL()
+ AC_PROG_INTLTOOL([0.31], [no-xml])
+-AC_CHECK_PROGS([PERL], [perl5 perl])
+-
+-dnl ***************************************
+-dnl *** Check for required Perl modules ***
+-dnl ***************************************
+-AC_PROG_PERL_MODULES([URI::Escape URI::file URI::URL], [],
+-[
+- AC_MSG_ERROR([Atleast one of the required Perl modules (URI::Escape, URI::file and URI::URL) was not found on your system])
+-])
+
+ dnl ***************************************
+ dnl *** Check for standard header files ***
+@@ -165,17 +156,6 @@ dnl ***********************************
+ dnl *** Check for required packages ***
+ dnl ***********************************
+ XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.30.0])
+-XDT_CHECK_PACKAGE([GIO], [gio-2.0], [2.30.0])
+-XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.24.0])
+-XDT_CHECK_PACKAGE([GTHREAD], [gthread-2.0], [2.30.0])
+-XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.10.0])
+-XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.10.0])
+-XDT_CHECK_OPTIONAL_PACKAGE([GIO_UNIX], [gio-unix-2.0], [2.30.0], [gio-unix], [GIO-Unix features])
+-
+-dnl *********************
+-dnl *** Check for X11 ***
+-dnl *********************
+-XDT_CHECK_LIBX11_REQUIRE()
+
+ dnl *************************
+ dnl *** Check for gtk-doc ***
+--
+1.7.4.4
+
diff --git a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
index 6aa1056492..f16d5444c9 100644
--- a/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
+++ b/meta-xfce/recipes-xfce/exo/exo_0.10.2.bb
@@ -3,7 +3,8 @@ SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo"
-PR = "r1"
+DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native"
+PR = "r2"
inherit xfce pythonnative perlnative
@@ -14,6 +15,10 @@ SRC_URI += " \
file://gnome-mount \
"
+SRC_URI_append_class-native = " \
+ file://reduce-build-to-exo-csource-only.patch \
+"
+
SRC_URI[md5sum] = "c70f2a217811bfba2e62f938d4b8f748"
SRC_URI[sha256sum] = "b385828bf8a38204da3254b57fdfa25a72694495aa189fabd5040f707eec76ce"
@@ -31,3 +36,5 @@ FILES_${PN} += "${datadir}/xfce4/ \
FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \
"
+
+BBCLASSEXTEND = "native"