aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-05-25 11:48:20 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-05-28 10:35:15 +0200
commit3c9f68dc455d1ce7ab472eef9a1af3550fc578fa (patch)
tree0c3775cb31864e2dbcc05419e14eaf1ea3887660 /meta-xfce
parent2be2cbf444394e86c8ae924e423c97166c48311d (diff)
downloadmeta-openembedded-contrib-3c9f68dc455d1ce7ab472eef9a1af3550fc578fa.tar.gz
meta-openembedded-contrib-3c9f68dc455d1ce7ab472eef9a1af3550fc578fa.tar.bz2
meta-openembedded-contrib-3c9f68dc455d1ce7ab472eef9a1af3550fc578fa.zip
xfce4-notes-plugin: update to 1.8.0
removed patch is upstream Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
Diffstat (limited to 'meta-xfce')
-rw-r--r--meta-xfce/recipes-panel-plugins/notes/files/0001-Bump-dependency-to-Xfce-4.10.patch128
-rw-r--r--meta-xfce/recipes-panel-plugins/notes/files/0001-main-status-icon.c-remove-deprecated-g_type_init.patch (renamed from meta-xfce/recipes-panel-plugins/notes/files/0002-main-status-icon.c-remove-deprecated-g_type_init.patch)0
-rw-r--r--meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.8.0.bb (renamed from meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.7.7.bb)7
3 files changed, 3 insertions, 132 deletions
diff --git a/meta-xfce/recipes-panel-plugins/notes/files/0001-Bump-dependency-to-Xfce-4.10.patch b/meta-xfce/recipes-panel-plugins/notes/files/0001-Bump-dependency-to-Xfce-4.10.patch
deleted file mode 100644
index 4a3b1ce586..0000000000
--- a/meta-xfce/recipes-panel-plugins/notes/files/0001-Bump-dependency-to-Xfce-4.10.patch
+++ /dev/null
@@ -1,128 +0,0 @@
-From 26c4ad1765d0d59b3918363d38174c5f5bfe0dcd Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
-Date: Fri, 20 Sep 2013 22:49:47 +0200
-Subject: [PATCH] Bump dependency to Xfce 4.10
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Drop support for Xfce <= 4.6.
-Replace libxfcegui4 dependency against libxfce4ui.
-Update to new libtool syntax (use LT_PREREQ.)
-
-Upstream-status: Backport [1]
-
-[1] http://git.xfce.org/panel-plugins/xfce4-notes-plugin/commit/?id=d11fe51fae95b5b4963847be76ae4a07409a6076
-
-Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
----
- configure.ac | 23 ++++++++++-------------
- src/Makefile.am | 4 ++--
- src/xfce4-notes-settings.c | 6 +++---
- 3 files changed, 15 insertions(+), 18 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 20d27e5..8d4113f 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -24,21 +24,17 @@ AC_INIT([Notes], [xfce4_notes_plugin_version], [http://bugzilla.xfce.org/], [xfc
- AC_REVISION([xfce4_notes_plugin_version_build])
- AC_CANONICAL_TARGET()
-
-+LT_PREREQ([2.2.6])
-+LT_INIT([disable-static])
-+
- AM_INIT_AUTOMAKE([1.11 dist-bzip2])
- AM_CONFIG_HEADER([config.h])
- AM_MAINTAINER_MODE()
- AM_SILENT_RULES([yes])
-
--dnl Avoid g77 and g++ checks
--m4_undefine([AC_PROG_CXX])
--m4_defun([AC_PROG_CXX],[])
--m4_undefine([AC_PROG_F77])
--m4_defun([AC_PROG_F77],[])
--
- dnl Check for basic programs
- AM_PROG_CC_C_O()
- AC_PROG_LD()
--AC_PROG_LIBTOOL()
- AC_PROG_INSTALL()
- AC_PROG_INTLTOOL()
-
-@@ -51,12 +47,13 @@ AC_SUBST([MATH_LIBS], [" -lm"])
-
- dnl Check for required packages
- XDT_CHECK_LIBX11_REQUIRE()
--XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.16.0])
--XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.14.0])
--XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.4.0])
--XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.4.0])
--XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.4.0])
--XDT_CHECK_PACKAGE([XFCONF], [libxfconf-0], [4.6.0])
-+XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.24.0])
-+XDT_CHECK_PACKAGE([GIO], [gio-2.0], [2.24.0])
-+XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.20.0])
-+XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.10.0])
-+XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.10.0])
-+XDT_CHECK_PACKAGE([LIBXFCE4PANEL], [libxfce4panel-1.0], [4.10.0])
-+XDT_CHECK_PACKAGE([XFCONF], [libxfconf-0], [4.10.0])
- XDT_CHECK_PACKAGE([UNIQUE], [unique-1.0], [1.0.0])
-
- dnl Check for libxfce4panel >= 4.7
-diff --git a/src/Makefile.am b/src/Makefile.am
-index f69ab0f..2d97b63 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -36,7 +36,7 @@ xfce4_notes_settings_SOURCES = \
- xfce4_notes_settings_CFLAGS = \
- @LIBX11_CFLAGS@ \
- @GTK_CFLAGS@ \
-- @LIBXFCEGUI4_CFLAGS@ \
-+ @LIBXFCE4UI_CFLAGS@ \
- @XFCONF_CFLAGS@ \
- @UNIQUE_CFLAGS@
-
-@@ -44,7 +44,7 @@ xfce4_notes_settings_LDADD = \
- $(top_builddir)/lib/libnotes.la \
- @LIBX11_LIBS@ \
- @GTK_LIBS@ \
-- @LIBXFCEGUI4_LIBS@ \
-+ @LIBXFCE4UI_LIBS@ \
- @XFCONF_LIBS@ \
- @UNIQUE_LIBS@
-
-diff --git a/src/xfce4-notes-settings.c b/src/xfce4-notes-settings.c
-index f66bb13..1d7cc70 100644
---- a/src/xfce4-notes-settings.c
-+++ b/src/xfce4-notes-settings.c
-@@ -25,7 +25,7 @@
- #include <xfconf/xfconf.h>
- #include <gtk/gtk.h>
- #include <libxfce4util/libxfce4util.h>
--#include <libxfcegui4/libxfcegui4.h>
-+#include <libxfce4ui/libxfce4ui.h>
-
- #include "defines.h"
- #include "color.h"
-@@ -115,7 +115,7 @@ prop_dialog_new (void)
-
- /* === Global settings === */
- box = gtk_vbox_new (FALSE, BORDER);
-- frame = xfce_create_framebox_with_content (_("Global settings"), box);
-+ frame = xfce_gtk_frame_box_new_with_content (_("Global settings"), box);
- gtk_container_set_border_width (GTK_CONTAINER (frame), BORDER);
- gtk_container_add (GTK_CONTAINER (vbox), frame);
-
-@@ -163,7 +163,7 @@ prop_dialog_new (void)
-
- /* === New window settings === */
- box = gtk_vbox_new (FALSE, BORDER);
-- frame = xfce_create_framebox_with_content (_("New group settings"), box);
-+ frame = xfce_gtk_frame_box_new_with_content (_("New group settings"), box);
- gtk_container_set_border_width (GTK_CONTAINER (frame), BORDER);
- gtk_container_add (GTK_CONTAINER (vbox), frame);
-
---
-1.8.3.1
-
diff --git a/meta-xfce/recipes-panel-plugins/notes/files/0002-main-status-icon.c-remove-deprecated-g_type_init.patch b/meta-xfce/recipes-panel-plugins/notes/files/0001-main-status-icon.c-remove-deprecated-g_type_init.patch
index e1ede27c42..e1ede27c42 100644
--- a/meta-xfce/recipes-panel-plugins/notes/files/0002-main-status-icon.c-remove-deprecated-g_type_init.patch
+++ b/meta-xfce/recipes-panel-plugins/notes/files/0001-main-status-icon.c-remove-deprecated-g_type_init.patch
diff --git a/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.7.7.bb b/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.8.0.bb
index fee5a4d9c4..451ec551fc 100644
--- a/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.7.7.bb
+++ b/meta-xfce/recipes-panel-plugins/notes/xfce4-notes-plugin_1.8.0.bb
@@ -8,11 +8,10 @@ inherit xfce-panel-plugin
DEPENDS = "gtk+ libxfce4ui xfce4-panel xfconf libunique"
SRC_URI += " \
- file://0001-Bump-dependency-to-Xfce-4.10.patch \
- file://0002-main-status-icon.c-remove-deprecated-g_type_init.patch \
+ file://0001-main-status-icon.c-remove-deprecated-g_type_init.patch \
"
-SRC_URI[md5sum] = "42b924b23f2fec6a1099e9b7a87db4a3"
-SRC_URI[sha256sum] = "a7baa105b37ad05dea4d6b55d98fd3214c77ad5c7a0e91471d4906c81e5f5217"
+SRC_URI[md5sum] = "569341bc27e2e46d23b6bffc14bff41a"
+SRC_URI[sha256sum] = "3627b7da0533ca3fb10310f287dc0d569470960ffdaea7678fd878a20d409678"
FILES_${PN} += "${libdir}/xfce4/panel-plugins/*.so.*"