aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-flask.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-flask_0.10.1.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-flask_0.10.1.bb2
3 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask.inc b/meta-python/recipes-devtools/python/python-flask.inc
new file mode 100644
index 0000000000..4923726a3e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask.inc
@@ -0,0 +1,14 @@
+SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions"
+DESCRIPTION = "\
+Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \
+intentions. And before you ask: It’s BSD licensed!"
+HOMEPAGE = "https://github.com/mitsuhiko/flask/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=79aa8b7bc4f781210d6b5c06d6424cb0"
+
+SRC_URI[md5sum] = "378670fe456957eb3c27ddaef60b2b24"
+SRC_URI[sha256sum] = "4c83829ff83d408b5e1d4995472265411d2c414112298f2eb4b359d9e4563373"
+
+PYPI_PACKAGE = "Flask"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-werkzeug ${PYTHON_PN}-jinja2 ${PYTHON_PN}-itsdangerous"
diff --git a/meta-python/recipes-devtools/python/python-flask_0.10.1.bb b/meta-python/recipes-devtools/python/python-flask_0.10.1.bb
new file mode 100644
index 0000000000..7ec8123a2b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-flask_0.10.1.bb
@@ -0,0 +1,2 @@
+inherit pypi
+require python-flask.inc
diff --git a/meta-python/recipes-devtools/python/python3-flask_0.10.1.bb b/meta-python/recipes-devtools/python/python3-flask_0.10.1.bb
new file mode 100644
index 0000000000..1ab2c02b72
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask_0.10.1.bb
@@ -0,0 +1,2 @@
+inherit pypi3
+require python-flask.inc