aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb6
-rw-r--r--meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb6
2 files changed, 10 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb b/meta-python/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
index ca0eb32638..9cd881a3ef 100644
--- a/meta-python/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
+++ b/meta-python/recipes-devtools/python/python-ndg-httpsclient_0.5.1.bb
@@ -1,2 +1,6 @@
require python-ndg-httpsclient.inc
-inherit pypi setuptools
+inherit pypi setuptools update-alternatives
+
+ALTERNATIVE_${PN} = "ndg_httpclient"
+ALTERNATIVE_LINK_NAME[ndg_httpclient] = "${bindir}/ndg_httpclient"
+ALTERNATIVE_PRIORITY = "20"
diff --git a/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb b/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
index 3f07b2ed27..65a8c816f4 100644
--- a/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
@@ -1,2 +1,6 @@
-inherit pypi setuptools3
+inherit pypi setuptools3 update-alternatives
require python-ndg-httpsclient.inc
+
+ALTERNATIVE_${PN} = "ndg_httpclient"
+ALTERNATIVE_LINK_NAME[ndg_httpclient] = "${bindir}/ndg_httpclient"
+ALTERNATIVE_PRIORITY = "30"