aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb b/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
index e074b51971..208ac3c58b 100644
--- a/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
+++ b/meta-filesystems/recipes-utils/ufs-tool/ufs-tool_git.bb
@@ -12,8 +12,11 @@ SRC_URI = "git://github.com/westerndigitalcorporation/ufs-tool.git;protocol=git;
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}""
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} CC="${CC}" CFLAGS="${CFLAGS}""
+do_configure() {
+ sed -i -e "s|-static$||g" ${S}/Makefile
+}
do_install() {
install -d ${D}${bindir}/
install -c -m 755 ${S}/ufs-tool ${D}${bindir}/