aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/mg/mg_20161005.bb (renamed from meta-oe/recipes-support/mg/mg_20110905.bb)20
1 files changed, 9 insertions, 11 deletions
diff --git a/meta-oe/recipes-support/mg/mg_20110905.bb b/meta-oe/recipes-support/mg/mg_20161005.bb
index 95aeb62a3b..f9ceb4665c 100644
--- a/meta-oe/recipes-support/mg/mg_20110905.bb
+++ b/meta-oe/recipes-support/mg/mg_20161005.bb
@@ -1,15 +1,13 @@
SUMMARY = "A portable version of the mg maintained by the OpenBSD team"
HOMEPAGE = "http://homepage.boetes.org/software/mg/"
LICENSE = "PD"
-LIC_FILES_CHKSUM = "file://version.c;md5=811e1b67a5cd60c12b218a2b7c1adbf2"
-DEPENDS = "ncurses"
+LIC_FILES_CHKSUM = "file://version.c;md5=1895eb37bf6bd79cdc5c89d8166fabfb"
+DEPENDS = "ncurses libbsd"
SECTION = "console/editors"
-SRC_URI = "http://homepage.boetes.org/software/mg/mg-${PV}.tar.gz \
- file://remove_ncurses_check.patch"
-
-SRC_URI[md5sum] = "2de35316fa8ebafe6003efaae70b723e"
-SRC_URI[sha256sum] = "1cd37d7e6a3eecc890a5718c38b8f38495057ba93856762a756ccee2f9618229"
+SRC_URI = "http://homepage.boetes.org/software/mg/mg-${PV}.tar.gz"
+SRC_URI[md5sum] = "fc6faeeee7308bb46f3512b75867ed51"
+SRC_URI[sha256sum] = "b7fcb5136a6783ca24c8463ab0852fc1f26bdb2bb1c24759b2c51ccfc46c5e61"
# CFLAGS isn't in EXTRA_OEMAKE, as the makefile picks it up via ?=
EXTRA_OEMAKE = "\
@@ -21,13 +19,13 @@ EXTRA_OEMAKE = "\
'libdir=${libdir}' \
'includedir=${includedir}' \
'mandir=${mandir}' \
+ 'PKG_CONFIG=pkg-config' \
"
-do_configure () {
- sed -i Makefile.in -e 's,^prefix=.*,prefix=${prefix},'
- ./configure
-}
+CFLAGS += "-I${STAGING_INCDIR}/bsd"
do_install () {
oe_runmake install DESTDIR=${D}
}
+
+inherit pkgconfig