aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Extend-arm32-support-to-include-BE-variants.patch38
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch29
-rw-r--r--meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb2
3 files changed, 39 insertions, 30 deletions
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Extend-arm32-support-to-include-BE-variants.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Extend-arm32-support-to-include-BE-variants.patch
new file mode 100644
index 0000000000..f6147cbf35
--- /dev/null
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/files/0001-Extend-arm32-support-to-include-BE-variants.patch
@@ -0,0 +1,38 @@
+From 5af6dec8764375ca4f13bd9fed96af090228351a Mon Sep 17 00:00:00 2001
+From: "Gary S. Robertson" <gary.robertson@linaro.org>
+Date: Mon, 11 Aug 2014 11:06:04 -0500
+Subject: [libhugetlbfs][PATCH] Extend arm32 support to include BE variants
+
+This patch applies the same technique used by Koen Kool in the following patch
+which was accepted by the libhugetlbfs project:
+
+[0a4f6] Add aarch64_be_support 2014-03-31 10:52:37
+
+It modifies the libhugetlbfs Makefile to mark all 32-bit arm architectures
+as supported by the libhugetlbfs build. Builds and successful functional
+tests have been performed for armv7a LE and BE runtime platforms.
+
+This patch replaces and renders obsolete the following patch:
+arm32-support.patch submitted by: Chunrong Guo <B40290@freescale.com>
+
+Signed-off-by: Gary S. Robertson <gary.robertson@linaro.org>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 91502e1..ba79607 100644
+--- a/Makefile
++++ b/Makefile
+@@ -59,7 +59,7 @@ ELF32 = elf32ppclinux
+ TMPLIB32 = lib
+ CPPFLAGS += -DPPC_NO_SEGMENTS
+ else
+-ifeq ($(ARCH),armv7l)
++ifneq (,$(findstring arm,$(ARCH)))
+ CC32 = $(CC)
+ TMPLIB32 = lib
+ ELF32 += armelf_linux_eabi
+--
+1.7.9.5
+
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch b/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
deleted file mode 100644
index 96f162dd94..0000000000
--- a/meta-oe/recipes-benchmark/libhugetlbfs/files/arm32-support.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Upstream-Status: Submitted
-
-This patch adds support for arm32.
-
-Signed-off-by: Chunrong Guo <B40290@freescale.com>
-
---- a/Makefileold 2014-06-17 21:55:23.131058918 -0500
-+++ b/Makefile 2014-06-17 21:56:08.726098531 -0500
-@@ -59,6 +59,12 @@
- TMPLIB32 = lib
- CPPFLAGS += -DPPC_NO_SEGMENTS
- else
-+ifeq ($(ARCH),arm)
-+CC32 = $(CC)
-+TMPLIB32 = lib
-+ELF32 += armelf_linux_eabi
-+CUSTOM_LDSCRIPTS = no
-+else
- ifeq ($(ARCH),armv7l)
- CC32 = $(CC)
- TMPLIB32 = lib
-@@ -116,6 +122,7 @@
- endif
- endif
- endif
-+endif
-
- ifdef CC32
- OBJDIRS += obj32
diff --git a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
index 315863db75..851b050ebb 100644
--- a/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
+++ b/meta-oe/recipes-benchmark/libhugetlbfs/libhugetlbfs_git.bb
@@ -17,7 +17,7 @@ SRC_URI = "git://git.code.sf.net/p/libhugetlbfs/code \
file://0001-aarch64-fix-cross-compilation.patch \
file://0001-aarch64-fix-page-size-not-properly-computed.patch \
file://0001-replace-lib-lib64-hardcoded-values-by-LIBDIR32-LIBDI.patch \
- file://arm32-support.patch \
+ file://0001-Extend-arm32-support-to-include-BE-variants.patch \
"
S = "${WORKDIR}/git"