aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmeta-python/recipes-devtools/python/python-pytz.inc15
-rwxr-xr-x[-rw-r--r--]meta-python/recipes-devtools/python/python-pytz_2016.7.bb17
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-pytz_2016.7.bb2
3 files changed, 19 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytz.inc b/meta-python/recipes-devtools/python/python-pytz.inc
new file mode 100755
index 0000000000..19be2c7571
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pytz.inc
@@ -0,0 +1,15 @@
+SUMMARY = "World timezone definitions, modern and historical"
+HOMEPAGE = "http://pythonhosted.org/pytz"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=22b38951eb857cf285a4560a914b7cd6"
+
+inherit pypi
+
+SRC_URI[md5sum] = "8660ba7c3c0abd23e6e4efa493b02966"
+SRC_URI[sha256sum] = "8787de03f35f31699bcaf127e56ad14c00647965ed24d72dbaca87c6e4f843a3"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-threading \
+"
diff --git a/meta-python/recipes-devtools/python/python-pytz_2016.7.bb b/meta-python/recipes-devtools/python/python-pytz_2016.7.bb
index 508fd3b54f..f2ffc596f8 100644..100755
--- a/meta-python/recipes-devtools/python/python-pytz_2016.7.bb
+++ b/meta-python/recipes-devtools/python/python-pytz_2016.7.bb
@@ -1,15 +1,2 @@
-SUMMARY = "World timezone definitions, modern and historical"
-HOMEPAGE = " http://pythonhosted.org/pytz"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=22b38951eb857cf285a4560a914b7cd6"
-
-SRC_URI[md5sum] = "8660ba7c3c0abd23e6e4efa493b02966"
-SRC_URI[sha256sum] = "8787de03f35f31699bcaf127e56ad14c00647965ed24d72dbaca87c6e4f843a3"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-datetime \
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-threading \
-"
+inherit setuptools
+require python-pytz.inc
diff --git a/meta-python/recipes-devtools/python/python3-pytz_2016.7.bb b/meta-python/recipes-devtools/python/python3-pytz_2016.7.bb
new file mode 100755
index 0000000000..19a89dc55d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pytz_2016.7.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-pytz.inc