aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb
index 3cfa3f31f4..25709a1176 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.3.2.bb
@@ -26,6 +26,7 @@ inherit pypi setuptools3 pkgconfig
# LTO with clang needs lld
LDFLAGS_append_toolchain-clang = " -fuse-ld=lld"
+LDFLAGS_remove_toolchain-clang_mips = "-fuse-ld=lld"
RDEPENDS_${PN} = "\
freetype \
@@ -40,6 +41,7 @@ RDEPENDS_${PN} = "\
ENABLELTO_toolchain-clang_riscv64 = "echo enable_lto = False >> ${S}/setup.cfg"
ENABLELTO_toolchain-clang_riscv32 = "echo enable_lto = False >> ${S}/setup.cfg"
+ENABLELTO_toolchain-clang_mips = "echo enable_lto = False >> ${S}/setup.cfg"
do_compile_prepend() {
echo [libs] > ${S}/setup.cfg
echo system_freetype = true >> ${S}/setup.cfg