aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-support/postgresql/files/no-ecpg-test.patch12
-rw-r--r--recipes-support/postgresql/postgresql-8.4.4/remove.autoconf.version.check.patch15
-rw-r--r--recipes-support/postgresql/postgresql.inc65
-rw-r--r--recipes-support/postgresql/postgresql_8.4.4.bb9
4 files changed, 101 insertions, 0 deletions
diff --git a/recipes-support/postgresql/files/no-ecpg-test.patch b/recipes-support/postgresql/files/no-ecpg-test.patch
new file mode 100644
index 0000000000..c0f28f4258
--- /dev/null
+++ b/recipes-support/postgresql/files/no-ecpg-test.patch
@@ -0,0 +1,12 @@
+diff --git a/src/interfaces/ecpg/Makefile b/src/interfaces/ecpg/Makefile
+index dcd578f..1428423 100644
+--- a/src/interfaces/ecpg/Makefile
++++ b/src/interfaces/ecpg/Makefile
+@@ -8,7 +8,6 @@ all install installdirs uninstall dep depend distprep:
+ $(MAKE) -C ecpglib $@
+ $(MAKE) -C compatlib $@
+ $(MAKE) -C preproc $@
+- $(MAKE) -C test $@
+
+ clean distclean maintainer-clean:
+ -$(MAKE) -C include $@
diff --git a/recipes-support/postgresql/postgresql-8.4.4/remove.autoconf.version.check.patch b/recipes-support/postgresql/postgresql-8.4.4/remove.autoconf.version.check.patch
new file mode 100644
index 0000000000..d027061d89
--- /dev/null
+++ b/recipes-support/postgresql/postgresql-8.4.4/remove.autoconf.version.check.patch
@@ -0,0 +1,15 @@
+Index: postgresql-8.4.4/configure.in
+===================================================================
+--- postgresql-8.4.4.orig/configure.in
++++ postgresql-8.4.4/configure.in
+@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch un
+
+ AC_INIT([PostgreSQL], [8.4.4], [pgsql-bugs@postgresql.org])
+
+-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.61], [], [m4_fatal([Autoconf version 2.61 is required.
+-Untested combinations of 'autoconf' and PostgreSQL versions are not
+-recommended. You can remove the check from 'configure.in' but it is then
+-your responsibility whether the result works or not.])])
+ AC_COPYRIGHT([Copyright (c) 1996-2009, PostgreSQL Global Development Group])
+ AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
+ AC_CONFIG_AUX_DIR(config)
diff --git a/recipes-support/postgresql/postgresql.inc b/recipes-support/postgresql/postgresql.inc
new file mode 100644
index 0000000000..54a046e568
--- /dev/null
+++ b/recipes-support/postgresql/postgresql.inc
@@ -0,0 +1,65 @@
+DESCRIPTION = "PostgreSQL is a powerful, open source relational database system."
+HOMEPAGE = "http://www.postgresql.com"
+LICENSE = "BSD"
+DEPENDS = "zlib readline"
+
+ARM_INSTRUCTION_SET = "arm"
+
+#WARNING: this recipe assumes you have the timezone compiler present in /usr/sbin/zic
+
+SRC_URI = "ftp://ftp-archives.postgresql.org/pub/source/v${PV}/${P}.tar.bz2"
+
+LEAD_SONAME = "libpq.so"
+
+# LDFLAGS for shared libraries
+export LDFLAGS_SL = "${LDFLAGS}"
+
+inherit autotools pkgconfig
+
+do_compile_append() {
+ cp /usr/sbin/zic ${S}/src/timezone/
+}
+
+PACKAGES =+ "${PN}-client ${PN}-server-dev ${PN}-timezone \
+ libecpg-compat-dbg libecpg-compat \
+ libecpg-dbg libecpg libecpg-dev \
+ libpq-dbg libpq libpq-dev \
+ libpgtypes-dbg libpgtypes "
+
+FILES_${PN}-client = "${bindir}/clusterdb \
+ ${bindir}/createdb \
+ ${bindir}/createlang \
+ ${bindir}/createuser \
+ ${bindir}/dropdb \
+ ${bindir}/droplang \
+ ${bindir}/dropuser \
+ ${bindir}/pg_dump \
+ ${bindir}/pg_dumpall \
+ ${bindir}/pg_restore \
+ ${bindir}/psql \
+ ${bindir}/reindexdb \
+ ${bindir}/vacuumdb \
+ ${bindir}/vacuumlo \
+ ${datadir}/${PN}/psqlrc.sample"
+
+FILES_${PN}-doc += "${prefix}/doc/"
+FILES_${PN}-timezone = "${datadir}/${PN}/timezone"
+FILES_${PN}-server-dev = "${includedir}/${PN}/server"
+
+FILES_libecpg = "${libdir}/libecpg*.so.*"
+FILES_libecpg-dbg = "${libdir}/.debug/libecpg*"
+FILES_libecpg-dev = "${libdir}/libecpg*.a ${libdir}/libecpg*.so \
+ ${libdir}/libpgtypes*.a ${libdir}/libpgtypes*.so \
+ ${includedir}/ecpg*.h ${includedir}/${PN}/ecpg*.h \
+ ${includedir}/pgtypes*.h ${includedir}/${PN}/informix \
+ ${includedir}/sql3types.h ${includedir}/sqlca.h"
+
+FILES_libpq = "${libdir}/libpq*.so.*"
+FILES_libpq-dbg = "${libdir}/.debug/libpq* ${libdir}/${PN}/pgxs/src/test/regress/.debug/*"
+FILES_libpq-dev = "${libdir}/libpq*.a ${libdir}/libpq*.so ${libdir}/libpgport.a \
+ ${includedir}"
+
+FILES_libecpg-compat = "${libdir}/libecpg_compat*.so.*"
+FILES_libecpg-compat-dbg = "${libdir}/.debug/libecpg_compat*"
+FILES_libpgtypes = "${libdir}/libpgtypes*.so.*"
+FILES_libpgtypes-dbg = "${libdir}/.debug/libpgtypes*"
diff --git a/recipes-support/postgresql/postgresql_8.4.4.bb b/recipes-support/postgresql/postgresql_8.4.4.bb
new file mode 100644
index 0000000000..0ec1769ebf
--- /dev/null
+++ b/recipes-support/postgresql/postgresql_8.4.4.bb
@@ -0,0 +1,9 @@
+require postgresql.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "ftp://ftp.postgresql.org/pub/source/v${PV}/${P}.tar.bz2 \
+ file://remove.autoconf.version.check.patch"
+
+SRC_URI[md5sum] = "4bf2448ad965bca3940df648c02194df"
+SRC_URI[sha256sum] = "e66b398d565f7fb16d8ae58ae72881dcd3dbb1b88f532bbe1c2d1284812be37e"