aboutsummaryrefslogtreecommitdiffstats
path: root/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb')
-rw-r--r--meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb b/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb
new file mode 100644
index 0000000000..11b01f6a9f
--- /dev/null
+++ b/meta-efl/recipes-efl/packagegroups/packagegroup-x11-illume.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "The Illume Windowing Environment -- install this task to get the Enlightenment Window Manager + the Illume environment."
+SECTION = "x11/wm"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${TOPDIR}/meta-openembedded/meta-efl/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PV = "1.0"
+PR = "r5"
+
+inherit packagegroup allarch
+
+# Default theme and config
+ETHEME ?= "e-wm-theme-default"
+ECONFIG ?= "e-wm-config-mobile"
+
+RPROVIDES_${PN} += "task-x11-illume"
+RREPLACES_${PN} += "task-x11-illume"
+RCONFLICTS_${PN} += "task-x11-illume"
+RDEPENDS_${PN} = "\
+ packagegroup-core-x11-xserver \
+ packagegroup-core-x11-utils \
+ \
+ e-wm \
+ ${ECONFIG} \
+ ${ETHEME} \
+"