aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/conf/layer.conf')
-rw-r--r--meta-gnome/conf/layer.conf22
1 files changed, 16 insertions, 6 deletions
diff --git a/meta-gnome/conf/layer.conf b/meta-gnome/conf/layer.conf
index e6e9532b41..f831de78c4 100644
--- a/meta-gnome/conf/layer.conf
+++ b/meta-gnome/conf/layer.conf
@@ -6,16 +6,26 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "gnome-layer"
BBFILE_PATTERN_gnome-layer := "^${LAYERDIR}/"
-BBFILE_PRIORITY_gnome-layer = "7"
+BBFILE_PRIORITY_gnome-layer = "5"
+
+# auto-pack gnome help files
+IMAGE_LINGUAS_COMPLEMENTARY:append = " ${@bb.utils.contains('DISTRO_FEATURES','helpfiles','*-help-%s','',d)}"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_gnome-layer = "1"
-LAYERDEPENDS_gnome-layer = "core openembedded-layer networking-layer"
+LAYERDEPENDS_gnome-layer = "core openembedded-layer networking-layer meta-python"
+
+LAYERSERIES_COMPAT_gnome-layer = "styhead"
-LAYERSERIES_COMPAT_gnome-layer = "sumo"
+SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += "\
+ faenza-icon-theme->gdk-pixbuf \
+ faenza-icon-theme->gtk+3 \
+"
-# Sanity check for meta-gnome layer.
-# Setting SKIP_META_GNOME_SANITY_CHECK to "1" would skip the bbappend files check.
-INHERIT += "sanity-meta-gnome"
+BBFILES_DYNAMIC += " \
+ virtualization-layer:${LAYERDIR}/dynamic-layers/meta-virtualization/*/*/*.bb \
+ virtualization-layer:${LAYERDIR}/dynamic-layers/meta-virtualization/*/*/*.bbappend \
+ security:${LAYERDIR}/dynamic-layers/meta-security/*/*/*.bb \
+"