aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb')
-rw-r--r--meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb b/meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb
new file mode 100644
index 0000000000..58beaf6c57
--- /dev/null
+++ b/meta-gnome/recipes-extended/gparted/gparted_0.31.0.bb
@@ -0,0 +1,40 @@
+SUMMARY = "A partition editor to graphically manage disk partitions "
+HOMEPAGE = "http://gparted.org/index.php"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+inherit distro_features_check autotools pkgconfig gtk-icon-cache
+
+REQUIRED_DISTRO_FEATURES = "x11"
+
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \
+ file://org.yoctoproject.pkexec.run-gparted.policy \
+ file://gparted_polkit \
+"
+SRC_URI[md5sum] = "c554cc5734c50459dd551bd3fa10710e"
+SRC_URI[sha256sum] = "3b7b49a434d9e4b397bc41a1f5acab8539b9ff402b472dfd83ad77b2decd07ba"
+
+DEPENDS = "glib-2.0 glib-2.0-native gtkmm parted gnome-doc-utils intltool-native"
+
+do_install_append() {
+ # Add a script which checks if polkit is installed.
+ # If yes: a policy is requested from polkit / otherwise start as usual
+ install ${WORKDIR}/gparted_polkit ${D}${sbindir}
+ sed -i 's:%sbindir%:${sbindir}:g' ${D}${sbindir}/gparted_polkit
+ # relink menu entry to use our script
+ sed -i 's:${sbindir}/gparted:${sbindir}/gparted_polkit:g' ${D}${datadir}/applications/gparted.desktop
+
+ install -d ${D}${datadir}/polkit-1/actions
+ install ${WORKDIR}/org.yoctoproject.pkexec.run-gparted.policy ${D}${datadir}/polkit-1/actions/org.yoctoproject.pkexec.run-gparted.policy
+}
+
+EXTRA_OECONF = "--disable-scrollkeeper --disable-doc"
+
+FILES_${PN} += " \
+ ${datadir}/appdata \
+ ${datadir}/icons \
+ ${datadir}/polkit-1 \
+"
+
+RDEPENDS_${PN} = "dosfstools mtools e2fsprogs"