aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/eds/evolution-data-server
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/eds/evolution-data-server')
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch39
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch33
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch53
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0002-Fix-for-automake-1.12.x.patch32
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0003-Disable-Werror-for-automake.patch97
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch (renamed from meta-gnome/recipes-gnome/eds/evolution-data-server/0001-contact-Replace-the-Novell-sample-contact-with-somet.patch)21
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch39
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch77
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server/0006-configure.ac-do-not-overwrite-localedir.patch34
9 files changed, 96 insertions, 329 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch
new file mode 100644
index 0000000000..a821a14ab8
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch
@@ -0,0 +1,39 @@
+From 131b88a81aba3d72d566bc8a9d968941a98e0007 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Tue, 19 Dec 2017 16:37:20 +0100
+Subject: [PATCH] CMakeLists.txt: Remove TRY_RUN for iconv
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+| CMake Error: TRY_RUN() invoked in cross-compiling mode, please set the following cache variables appropriately:
+| _correct_iconv_EXITCODE (advanced)
+
+Upstream-Status: Inappropriate [OE specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ CMakeLists.txt | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8d07772..a2396f2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -521,13 +521,8 @@ if(NOT HAVE_ICONV)
+ endif(NOT HAVE_ICONV)
+
+ set(CMAKE_REQUIRED_LIBRARIES ${ICONV_LIBS})
+-CHECK_C_SOURCE_RUNS("#include \"${CMAKE_SOURCE_DIR}/iconv-detect.c\"" _correct_iconv)
+ unset(CMAKE_REQUIRED_LIBRARIES)
+
+-if(NOT _correct_iconv)
+- message(FATAL_ERROR "You need to install a working iconv implementation, such as ftp://ftp.gnu.org/pub/gnu/libiconv")
+-endif(NOT _correct_iconv)
+-
+ # ******************************
+ # Backtraces for debugging
+ # ******************************
+--
+2.14.3
+
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch
deleted file mode 100644
index f82a76df33..0000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-imapx-Fix-signature-for-imapx_tokenise_struct.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From 0e10e976025b21d12df099e82951f759024ad649 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Thu, 24 Aug 2017 22:04:56 -0700
-Subject: [PATCH] imapx: Fix signature for imapx_tokenise_struct()
-
-clang complains about different signature for this patch
-
-Fixes
-camel/providers/imapx/camel-imapx-tokens.txt:56:1: error: conflicting types for 'imapx_tokenise_struct'
-| imapx_tokenise_struct (register const char *str, register size_t len)
-| ^
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- camel/providers/imapx/camel-imapx-tokens.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/camel/providers/imapx/camel-imapx-tokens.txt b/camel/providers/imapx/camel-imapx-tokens.txt
-index d48501865..994c368c0 100644
---- a/camel/providers/imapx/camel-imapx-tokens.txt
-+++ b/camel/providers/imapx/camel-imapx-tokens.txt
-@@ -1,7 +1,7 @@
- /* This contains all of the keywords we care about. These
- can be converted to an id very efficiently */
- struct _imapx_keyword {const gchar *name; camel_imapx_id_t id; };
--struct _imapx_keyword *imapx_tokenise_struct (register const char *str, register unsigned int len);
-+struct _imapx_keyword *imapx_tokenise_struct (register const char *str, register size_t len);
- %%
- ALERT, IMAPX_ALERT
- APPENDUID, IMAPX_APPENDUID
---
-2.14.1
-
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
new file mode 100644
index 0000000000..c8dc7e12c6
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch
@@ -0,0 +1,53 @@
+From 210b204d9edd71202454ff04013cc52b23c598e4 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Tue, 19 Dec 2017 16:55:13 +0100
+Subject: [PATCH] CMakeLists.txt: remove CHECK_C_SOURCE_RUNS check
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+* TRY_RUN: does not work for OE
+* HAVE_LKSTRFTIME is set by recipe as configure option
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ CMakeLists.txt | 23 -----------------------
+ 1 file changed, 23 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a2396f2..f3b271b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -573,29 +573,6 @@ CHECK_C_SOURCE_COMPILES("#include <langinfo.h>
+ CHECK_C_SOURCE_COMPILES("#include <langinfo.h>
+ int main(void) { char *detail = nl_langinfo (_NL_ADDRESS_COUNTRY_AB2); return 0; }" HAVE__NL_ADDRESS_COUNTRY_AB2)
+
+-# *******************************************************
+-# Check to see if strftime supports the use of %l and %k
+-# *******************************************************
+-
+-CHECK_C_SOURCE_RUNS("
+- #include <stdlib.h>
+- #include <string.h>
+- #include <time.h>
+- int main(int argc, char **argv) {
+- char buf[10];
+- time_t rawtime;
+- struct tm *timeinfo;
+-
+- time(&rawtime);
+- timeinfo=localtime(&rawtime);
+- buf[0] = 0;
+- strftime(buf, 10, \"%lx%k\", timeinfo);
+-
+- if (!buf[0] || buf[0] == 'x' || strstr(buf, \"l\") || strstr(buf, \"k\"))
+- return 1;
+- return 0;
+- }" HAVE_LKSTRFTIME)
+-
+ # ******************************
+ # system mail stuff
+ # ******************************
+--
+2.14.3
+
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-Fix-for-automake-1.12.x.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-Fix-for-automake-1.12.x.patch
deleted file mode 100644
index 5f222aeaa9..0000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0002-Fix-for-automake-1.12.x.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From f46423c9e4b8b19eda27b307456a717de79b75f3 Mon Sep 17 00:00:00 2001
-From: Nitin A Kamble <nitin.a.kamble@intel.com>
-Date: Sun, 4 Aug 2013 09:15:43 +0200
-Subject: [PATCH 2/5] Fix for automake-1.12.x
-
-Fixed these kinds if warning-errors
-
-warning: 'libebookbackendfile.la': linking libtool libraries using a non-POSIX archiver requires 'AM_PROG_AR' in 'configure.ac'
-
-Upstream-Status: Pending
-
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- configure.ac | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/configure.ac b/configure.ac
-index 9bd97db..49d7506 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -31,6 +31,7 @@ AC_LANG(C)
-
- dnl Automake 1.11 - Silent Build Rules
- m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-+m4_ifdef([AM_PROG_AR], [AM_PROG_AR]) # required by automake 1.12
-
- dnl Required Package Versions
- m4_define([glib_minimum_version], [2.28])
---
-1.8.3.2
-
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-Disable-Werror-for-automake.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-Disable-Werror-for-automake.patch
deleted file mode 100644
index a182d4d5e8..0000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-Disable-Werror-for-automake.patch
+++ /dev/null
@@ -1,97 +0,0 @@
-From 37b227cff78fd4c652651662dafd71537280824e Mon Sep 17 00:00:00 2001
-From: Nitin A Kamble <nitin.a.kamble@intel.com>
-Date: Sun, 4 Aug 2013 09:16:59 +0200
-Subject: [PATCH 3/5] Disable Werror for automake
-
-Avoid these warning-errors
-
-automake: warnings are treated as errors
-Makefile.am:15: warning: '%'-style pattern rules are a GNU make extension
-Makefile.am:21: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-addressbook/backends/file/Makefile.am: installing './depcomp'
-addressbook/libebook/Makefile.am:55: warning: '%'-style pattern rules are a GNU make extension
-addressbook/libebook/Makefile.am:65: warning: '%'-style pattern rules are a GNU make extension
-addressbook/libebook/Makefile.am:66: warning: subst -,_,$*: non-POSIX variable name
-addressbook/libebook/Makefile.am:66: (probably a GNU make extension)
-addressbook/libebook/Makefile.am:72: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-addressbook/libedata-book/Makefile.am:2: warning: '%'-style pattern rules are a GNU make extension
-addressbook/libedata-book/Makefile.am:3: warning: subst -,_,$*: non-POSIX variable name
-addressbook/libedata-book/Makefile.am:3: (probably a GNU make extension)
-glib-gen.mak:9: warning: '%'-style pattern rules are a GNU make extension
-addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
-glib-gen.mak:13: warning: '%'-style pattern rules are a GNU make extension
-addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
-glib-gen.mak:18: warning: '%'-style pattern rules are a GNU make extension
-addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
-glib-gen.mak:26: warning: '%'-style pattern rules are a GNU make extension
-addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
-glib-gen.mak:38: warning: '%'-style pattern rules are a GNU make extension
-addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
-glib-gen.mak:41: warning: '%'-style pattern rules are a GNU make extension
-addressbook/libedata-book/Makefile.am:5: 'glib-gen.mak' included from here
-addressbook/libedata-book/Makefile.am:86: warning: '%'-style pattern rules are a GNU make extension
-addressbook/libedata-book/Makefile.am:101: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-calendar/backends/weather/Makefile.am:44: warning: '%'-style pattern rules are a GNU make extension
-calendar/libecal/Makefile.am:53: warning: '%'-style pattern rules are a GNU make extension
-calendar/libecal/Makefile.am:61: warning: '%'-style pattern rules are a GNU make extension
-calendar/libecal/Makefile.am:62: warning: subst -,_,$*: non-POSIX variable name
-calendar/libecal/Makefile.am:62: (probably a GNU make extension) calendar/libecal/Makefile.am:68: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-calendar/libedata-cal/Makefile.am:5: warning: '%'-style pattern rules are a GNU make extension
-calendar/libedata-cal/Makefile.am:6: warning: subst -,_,$*: non-POSIX variable name
-calendar/libedata-cal/Makefile.am:6: (probably a GNU make extension)
-glib-gen.mak:9: warning: '%'-style pattern rules are a GNU make extension
-calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
-glib-gen.mak:13: warning: '%'-style pattern rules are a GNU make extension
-calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
-glib-gen.mak:18: warning: '%'-style pattern rules are a GNU make extension
-calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
-glib-gen.mak:26: warning: '%'-style pattern rules are a GNU make extension
-calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
-glib-gen.mak:38: warning: '%'-style pattern rules are a GNU make extension
-calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
-glib-gen.mak:41: warning: '%'-style pattern rules are a GNU make extension
-calendar/libedata-cal/Makefile.am:8: 'glib-gen.mak' included from here
-calendar/libedata-cal/Makefile.am:71: warning: '%'-style pattern rules are a GNU make extension
-calendar/libedata-cal/Makefile.am:86: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-camel/Makefile.am:17: warning: '%'-style pattern rules are a GNU make extension
-libebackend/Makefile.am:35: warning: '%'-style pattern rules are a GNU make extension
-libebackend/Makefile.am:41: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-libedataserver/Makefile.am:91: warning: '%'-style pattern rules are a GNU make extension
-libedataserver/Makefile.am:97: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-libedataserverui/Makefile.am:108: warning: '%'-style pattern rules are a GNU make extension
-libedataserverui/Makefile.am:118: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-servers/google/libgdata-google/Makefile.am:27: warning: '%'-style pattern rules are a GNU make extension
-servers/google/libgdata-google/Makefile.am:33: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-servers/google/libgdata/Makefile.am:31: warning: '%'-style pattern rules are a GNU make extension
-servers/google/libgdata/Makefile.am:37: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-servers/groupwise/Makefile.am:85: warning: '%'-style pattern rules are a GNU make extension
-servers/groupwise/Makefile.am:91: warning: pkgconfig_DATA:-$(API_VERSION: non-POSIX variable name
-autoreconf: automake failed with exit status: 1
-
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-
-Conflicts:
- configure.ac
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 49d7506..1c802ff 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -21,7 +21,7 @@ m4_define([api_version], [1.2])
- dnl Autoconf / Automake Initialization
- AC_PREREQ(2.62)
- AC_INIT([evolution-data-server],[eds_version],[http://bugzilla.gnome.org/enter_bug.cgi?product=Evolution-Data-Server])
--AM_INIT_AUTOMAKE([gnu 1.10 tar-ustar dist-xz no-dist-gzip -Wall -Wno-portability -Werror foreign])
-+AM_INIT_AUTOMAKE([gnu 1.10 tar-ustar dist-xz no-dist-gzip -Wall -Wno-portability foreign])
- AC_CONFIG_MACRO_DIR([m4])
- AC_CONFIG_SRCDIR(README)
- AC_CONFIG_HEADERS(config.h)
---
-1.8.3.2
-
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-contact-Replace-the-Novell-sample-contact-with-somet.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch
index b77e7b9bd4..3cdfa8b6ff 100644
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0001-contact-Replace-the-Novell-sample-contact-with-somet.patch
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server/0003-contact-Replace-the-Novell-sample-contact-with-somet.patch
@@ -7,26 +7,13 @@ Subject: [PATCH 1/5] contact: Replace the Novell sample contact with something
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
- addressbook/backends/file/Makefile.am | 1 +
- addressbook/libedata-book/ximian-vcard.h | 179 ++++++++++++++++++-------------
+ src/addressbook/libedata-book/ximian-vcard.h | 179 ++++++++++++++++++-------------
2 files changed, 103 insertions(+), 77 deletions(-)
-diff --git a/addressbook/backends/file/Makefile.am b/addressbook/backends/file/Makefile.am
-index 08cf58f..17e7149 100644
---- a/addressbook/backends/file/Makefile.am
-+++ b/addressbook/backends/file/Makefile.am
-@@ -2,6 +2,7 @@ ebook_backend_LTLIBRARIES = libebookbackendfile.la
-
- libebookbackendfile_la_CPPFLAGS = \
- $(AM_CPPFLAGS) \
-+ -DCREATE_DEFAULT_VCARD \
- -DG_LOG_DOMAIN=\"libebookbackend\" \
- -I$(top_srcdir) \
- -I$(top_builddir) \
-diff --git a/addressbook/libedata-book/ximian-vcard.h b/addressbook/libedata-book/ximian-vcard.h
+diff --git a/src/addressbook/libedata-book/ximian-vcard.h b/src/addressbook/libedata-book/ximian-vcard.h
index 782d37b..5b0b250 100644
---- a/addressbook/libedata-book/ximian-vcard.h
-+++ b/addressbook/libedata-book/ximian-vcard.h
+--- a/src/addressbook/libedata-book/ximian-vcard.h
++++ b/src/addressbook/libedata-book/ximian-vcard.h
@@ -1,80 +1,105 @@
#define XIMIAN_VCARD \
"BEGIN:VCARD\n" \
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch
deleted file mode 100644
index 1383347988..0000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 2c73b588b9018cb59c666eae3a15fa1af42c56be Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Sun, 4 Aug 2013 10:57:08 +0200
-Subject: [PATCH 4/5] configure: Fix libical pkg-config trying to use host
- paths
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- calendar/libecal/libecal.pc.in | 2 +-
- configure.ac | 3 ++-
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/calendar/libecal/libecal.pc.in b/calendar/libecal/libecal.pc.in
-index fc6b359..d3435bb 100644
---- a/calendar/libecal/libecal.pc.in
-+++ b/calendar/libecal/libecal.pc.in
-@@ -12,4 +12,4 @@ Description: Client library for evolution calendars
- Version: @VERSION@
- Requires: libical >= @LIBICAL_REQUIRED@ libedataserver-1.2 gio-2.0
- Libs: -L${libdir} -lecal-1.2
--Cflags: -I${privincludedir} @LIBICAL_EXTRA_CFLAGS@
-+Cflags: -I${privincludedir}
-diff --git a/configure.ac b/configure.ac
-index 1c802ff..f1d4ce8 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1351,7 +1351,8 @@ dnl to differentiate between <libical/ical.h> and <ical.h>
- dnl We have fixed all our instances to use <libical/ical.h>. Until the .pc from
- dnl libical is fixed, we have to work-around the buggy CFlags.
- dnl *****
-- LIBICAL_EXTRA_CFLAGS=" -I`$PKG_CONFIG --variable=includedir libical` "
-+ m4_pattern_allow([^PKG_CONFIG_SYSROOT_DIR$])
-+ LIBICAL_EXTRA_CFLAGS=" -I$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=includedir libical` "
- LIBICAL_EXTRA_LIBS=""
- AC_SUBST(LIBICAL_EXTRA_CFLAGS)
- AC_SUBST(LIBICAL_EXTRA_LIBS)
---
-1.8.3.2
-
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch
deleted file mode 100644
index addf2ee8d3..0000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-From ac95e89749a01618f98b554a98e78d7c988bfc10 Mon Sep 17 00:00:00 2001
-From: Martin Jansa <Martin.Jansa@gmail.com>
-Date: Tue, 27 Nov 2012 08:46:51 +0100
-Subject: [PATCH 5/5] soup: adapt to new libxml2 API from 2.9.0
-
-* for more info see
- https://mail.gnome.org/archives/xml/2012-August/msg00005.html
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- calendar/backends/caldav/e-cal-backend-caldav.c | 21 +++++++++++++++++++++
- 1 file changed, 21 insertions(+)
-
-diff --git a/calendar/backends/caldav/e-cal-backend-caldav.c b/calendar/backends/caldav/e-cal-backend-caldav.c
-index 12f8f22..5555a3e 100644
---- a/calendar/backends/caldav/e-cal-backend-caldav.c
-+++ b/calendar/backends/caldav/e-cal-backend-caldav.c
-@@ -1172,8 +1172,13 @@ check_calendar_changed_on_server (ECalBackendCalDAV *cbdav)
- soup_message_set_request (message,
- "application/xml",
- SOUP_MEMORY_COPY,
-+#ifdef LIBXML2_NEW_BUFFER
-+ (gchar *) xmlOutputBufferGetContent(buf),
-+ xmlOutputBufferGetSize(buf));
-+#else
- (gchar *) buf->buffer->content,
- buf->buffer->use);
-+#endif
-
- /* Send the request now */
- send_and_handle_redirection (priv->session, message, NULL);
-@@ -1321,8 +1326,13 @@ caldav_server_list_objects (ECalBackendCalDAV *cbdav,
- soup_message_set_request (message,
- "application/xml",
- SOUP_MEMORY_COPY,
-+#ifdef LIBXML2_NEW_BUFFER
-+ (gchar *) xmlOutputBufferGetContent(buf),
-+ xmlOutputBufferGetSize(buf));
-+#else
- (gchar *) buf->buffer->content,
- buf->buffer->use);
-+#endif
-
- /* Send the request now */
- send_and_handle_redirection (priv->session, message, NULL);
-@@ -1715,8 +1725,14 @@ caldav_receive_schedule_outbox_url (ECalBackendCalDAV *cbdav)
- soup_message_set_request (message,
- "application/xml",
- SOUP_MEMORY_COPY,
-+#ifdef LIBXML2_NEW_BUFFER
-+ (gchar *) xmlOutputBufferGetContent(buf),
-+ xmlOutputBufferGetSize(buf));
-+#else
- (gchar *) buf->buffer->content,
- buf->buffer->use);
-+#endif
-+
-
- /* Send the request now */
- send_and_handle_redirection (priv->session, message, NULL);
-@@ -1765,8 +1781,13 @@ caldav_receive_schedule_outbox_url (ECalBackendCalDAV *cbdav)
- soup_message_set_request (message,
- "application/xml",
- SOUP_MEMORY_COPY,
-+#ifdef LIBXML2_NEW_BUFFER
-+ (gchar *) xmlOutputBufferGetContent(buf),
-+ xmlOutputBufferGetSize(buf));
-+#else
- (gchar *) buf->buffer->content,
- buf->buffer->use);
-+#endif
-
- /* Send the request now */
- send_and_handle_redirection (priv->session, message, NULL);
---
-1.8.3.2
-
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-configure.ac-do-not-overwrite-localedir.patch b/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-configure.ac-do-not-overwrite-localedir.patch
deleted file mode 100644
index 741e5e97d3..0000000000
--- a/meta-gnome/recipes-gnome/eds/evolution-data-server/0006-configure.ac-do-not-overwrite-localedir.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 3feaea8e84b3ad8dc2d551e42224f3b4a9413e7d Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
-Date: Thu, 3 Sep 2015 11:14:24 +0200
-Subject: [PATCH] configure.ac: do not overwrite localedir
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Upstream-Status: Backport [1]
-
-[1] https://git.gnome.org/browse/evolution-data-server/tree/configure.ac#n298
-
-Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
----
- configure.ac | 3 ---
- 1 file changed, 3 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index f1d4ce8..cee847f 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -257,9 +257,6 @@ GETTEXT_PACKAGE=evolution-data-server-$BASE_VERSION
- AC_SUBST(GETTEXT_PACKAGE)
- AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE, "$GETTEXT_PACKAGE", [Package name for gettext])
-
--localedir='$(prefix)/$(DATADIRNAME)/locale'
--AC_SUBST(localedir)
--
- dnl ******************************
- dnl Initialize libtool
- dnl ******************************
---
-2.1.0
-