aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb2
-rw-r--r--meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb2
-rw-r--r--meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb2
-rw-r--r--meta-gnome/recipes-support/goffice/goffice_0.8.17.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
index 8c3aab455e..60b970babe 100644
--- a/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
+++ b/meta-gnome/recipes-gnome/abiword/abiword_2.8.6.bb
@@ -99,7 +99,7 @@ FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings"
FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*"
FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
-PACKAGES_DYNAMIC = "${PN}-meta ${PN}-plugin-*"
+PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*"
python populate_packages_prepend () {
abiword_libdir = bb.data.expand('${libdir}/abiword-2.8/plugins', d)
diff --git a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
index 586eed84f4..46be86fce8 100644
--- a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
+++ b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb
@@ -40,7 +40,7 @@ FILES_${PN}-dbg += " ${libdir}/gnome-vfs-2.0/modules/.debug"
FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/include"
FILES_${PN}-doc += " ${datadir}/gtk-doc"
-PACKAGES_DYNAMIC = "gnome-vfs-plugin-*"
+PACKAGES_DYNAMIC += "^gnome-vfs-plugin-.*"
python populate_packages_prepend () {
print bb.data.getVar('FILES_gnome-vfs', d, 1)
diff --git a/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb b/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb
index c1f535bd4d..32b54ef0c0 100644
--- a/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb
+++ b/meta-gnome/recipes-gnome/gtk+/gtk+3_3.2.3.bb
@@ -72,7 +72,7 @@ FILES_${PN}-dbg += " \
${libdir}/gtk-3.0/modules/.debug"
-PACKAGES_DYNAMIC += "gtk3-immodule-* gtk3-printbackend-*"
+PACKAGES_DYNAMIC += "^gtk3-immodule-.* ^gtk3-printbackend-.*"
python populate_packages_prepend () {
import os.path
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
index c55a8acf61..4b6473149a 100644
--- a/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
+++ b/meta-gnome/recipes-support/goffice/goffice_0.8.17.bb
@@ -36,7 +36,7 @@ FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS}
${datadir}/idl ${datadir}/omf ${datadir}/sounds \
${libdir}/bonobo/servers"
-PACKAGES_DYNAMIC = "goffice-plugin-*"
+PACKAGES_DYNAMIC += "^goffice-plugin-.*"
python populate_packages_prepend () {
goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d)