aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gpe/recipes-support/fbreader/fbreader-0.12.10
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gpe/recipes-support/fbreader/fbreader-0.12.10')
-rw-r--r--meta-gpe/recipes-support/fbreader/fbreader-0.12.10/Makefile.patch22
-rw-r--r--meta-gpe/recipes-support/fbreader/fbreader-0.12.10/gcc45.patch20
2 files changed, 42 insertions, 0 deletions
diff --git a/meta-gpe/recipes-support/fbreader/fbreader-0.12.10/Makefile.patch b/meta-gpe/recipes-support/fbreader/fbreader-0.12.10/Makefile.patch
new file mode 100644
index 0000000000..0e498c7125
--- /dev/null
+++ b/meta-gpe/recipes-support/fbreader/fbreader-0.12.10/Makefile.patch
@@ -0,0 +1,22 @@
+diff -uri fbreader-0.12.1.orig/fbreader/Makefile fbreader-0.12.1/fbreader/Makefile
+--- fbreader-0.12.1.orig/fbreader/Makefile 2009-12-13 09:03:11.000000000 +0100
++++ fbreader-0.12.1/fbreader/Makefile 2009-12-14 17:18:47.548638783 +0100
+@@ -37,7 +37,6 @@
+ @install $(TARGET) $(DESTDIR)$(BINDIR)/FBReader
+ @install -d $(FBSHAREDIR)
+ @install -d $(FBSHAREDIR)/help
+- @./scripts/install_help.sh $(VARIANT) $(FBSHAREDIR)/help
+ @install -d $(FBSHAREDIR)/network
+ @install -m 0644 $(wildcard data/network/*.xml) $(FBSHAREDIR)/network
+ @install -d $(FBSHAREDIR)/network/certificates
+@@ -58,8 +57,8 @@
+ @install -d $(FBSHAREDIR)/resources
+ @install -m 0644 $(wildcard data/resources/*.xml) $(FBSHAREDIR)/resources
+ @install -d $(DESTDIR)$(APPIMAGEDIR_REAL)
+- @install -m 0644 $(wildcard data/icons/toolbar/$(VARIANT)/*.*) $(DESTDIR)$(APPIMAGEDIR_REAL)
+- @install -m 0644 $(wildcard data/icons/filetree/$(VARIANT)/*.*) $(DESTDIR)$(APPIMAGEDIR_REAL)
++ @install -m 0644 $(wildcard data/icons/toolbar/$(TARGET_ARCH)/*.*) $(DESTDIR)$(APPIMAGEDIR_REAL)
++ @install -m 0644 $(wildcard data/icons/filetree/$(TARGET_ARCH)/*.*) $(DESTDIR)$(APPIMAGEDIR_REAL)
+ @install -m 0644 $(wildcard data/icons/booktree/new/*.*) $(DESTDIR)$(APPIMAGEDIR_REAL)
+ @make -C $(TARGET_ARCH) RESOLUTION=$(RESOLUTION) install
+
diff --git a/meta-gpe/recipes-support/fbreader/fbreader-0.12.10/gcc45.patch b/meta-gpe/recipes-support/fbreader/fbreader-0.12.10/gcc45.patch
new file mode 100644
index 0000000000..00cba1023f
--- /dev/null
+++ b/meta-gpe/recipes-support/fbreader/fbreader-0.12.10/gcc45.patch
@@ -0,0 +1,20 @@
+ Fix compilation with gcc 4.5
+
+ [FBreader Ticket #340] -- http://old.fbreader.org/mantis/view.php?id=340
+
+ Without that patch we have:
+ Compiling Library.o ...Library.cpp:42:1: error: 'Library::Library' names the constructor, not the type
+
+ Upstream-Status: Accepted [Fixed in Version 0.14.0]
+
+--- fbreader-0.12.10-orig/fbreader/src/library/Library.cpp 2010-04-01 15:14:24.000000000 +0200
++++ fbreader-0.12.10/fbreader/src/library/Library.cpp 2010-04-13 13:34:06.000000000 +0200
+@@ -39,7 +39,7 @@
+ shared_ptr<Library> Library::ourInstance;
+ const size_t Library::MaxRecentListSize = 10;
+
+-Library::Library &Library::Instance() {
++Library &Library::Instance() {
+ if (ourInstance.isNull()) {
+ ourInstance = new Library();
+ }