aboutsummaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-bsp')
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot-klibc_git.bb6
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc3
-rw-r--r--meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb4
3 files changed, 7 insertions, 6 deletions
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-klibc_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-klibc_git.bb
index 0d6d00f6f1..da479c858c 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot-klibc_git.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot-klibc_git.bb
@@ -1,9 +1,9 @@
RDEPENDS_${PN} = "kexec-klibc"
PV = "0.5.9"
-PR = "r8+gitr${SRCREV}"
+PR = "r9+gitr${SRCREV}"
-SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
-SRCREV = "8f1d3cc3d9c650c6a6c88f83071185d6ee0ef9c7"
+SRC_URI = "git://github.com/kexecboot/kexecboot.git;protocol=git"
+SRCREV = "0daa774eac019602cd89048961e95985ea50dadf"
S = "${WORKDIR}/git"
# the binary is statically linked against klibc
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc b/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc
index a205904e4f..2a53f96ac3 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot.inc
@@ -43,11 +43,12 @@ do_install () {
install -d ${D}/proc
install -d ${D}/mnt
install -d ${D}/dev
+ install -d ${D}/sys
}
PACKAGE_ARCH = "${MACHINE_ARCH}"
-FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev"
+FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys"
pkg_postinst_${PN} () {
ln -sf ${bindir}/kexecboot $D/init
diff --git a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
index 13414615b6..b33b6400ce 100644
--- a/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
+++ b/meta-initramfs/recipes-bsp/kexecboot/kexecboot_git.bb
@@ -2,8 +2,8 @@ RDEPENDS_${PN} = "kexec"
PV = "0.5.9"
PR = "r8+gitr${SRCREV}"
-SRC_URI = "git://git.linuxtogo.org/home/groups/kexecboot/kexecboot.git;protocol=git "
-SRCREV = "8f1d3cc3d9c650c6a6c88f83071185d6ee0ef9c7"
+SRC_URI = "git://github.com/kexecboot/kexecboot.git;protocol=git"
+SRCREV = "0daa774eac019602cd89048961e95985ea50dadf"
S = "${WORKDIR}/git"
require kexecboot.inc